Results 1 to 9 of 9

Thread: Problem With wireless connection in BackTrack 5 R1

  1. #1
    Just burned his ISO
    Join Date
    Jan 2012
    Posts
    3

    Default Problem With wireless connection in BackTrack 5 R1

    Dear Friends I am new to this forum and backtrack OS.Recently I installed backTrack 5 R1 64 bit on my laptop however i can not access internet through my wireless card although it is working on my Windows 7.The wireless card model is Intel pro 3945ABG.This is some basic command which i use in terminal to find out more about the problem:

    root@root:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    root@root:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:21:9b:d2:6f:d9
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:16

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:49 errors:0 dropped:0 overruns:0 frame:0
    TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:6709 (6.7 KB) TX bytes:6709 (6.7 KB)

    root@root:~# lspci |grep 3945ABG
    0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

    I was wondering if someone can come up with solution to this problem.Thank you very much , i hope i didn't offend forum's intelligence with my question

  2. #2
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    6

    Default Re: Problem With wireless connection in BackTrack 5 R1

    What wireless card you use ? Is it KDE or Gnome ? Is it live cd, pesistent usb or on HDD ?

  3. #3
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Issue the following commands and post the output here.
    ifconfig -a
    dmesg | grep ipw
    Last edited by Snayler; 01-02-2012 at 08:24 PM.

  4. #4
    Senior Member cgelici's Avatar
    Join Date
    Feb 2010
    Location
    /root
    Posts
    121

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Maybe try ifconfig wlan0 up

  5. #5
    Just burned his ISO
    Join Date
    Jan 2012
    Posts
    3

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Dear Friends i tried the commands the you told me to preform and still no success on detecting the wireless card this is the result of terminal
    the dmesg | grep ipw command doesn't show anything

    root@root:~# ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:21:9b:d2:6f:d9
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:16

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:14 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:841 (841.0 B) TX bytes:841 (841.0 B)

    root@root:~# dmesg | grep ipw
    root@root:~# ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device
    root@root:~# ^C

    any idea?

  6. #6
    Senior Member cgelici's Avatar
    Join Date
    Feb 2010
    Location
    /root
    Posts
    121

    Default Re: Problem With wireless connection in BackTrack 5 R1

    http://intellinuxwireless.org/

    Maybe this helps, check it out

  7. #7
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Then try
    Code:
    dmesg | grep iwl

  8. #8
    Just burned his ISO
    Join Date
    Jan 2012
    Posts
    3

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Dear Snyler this command also doesn't show anything in Terminal and wireless still not detecting

    @ cgelici ,I believe these are all previous drivers which belongs to older Kernel ,but in this website http://www.backtrack-linux.org/wiki/...reless_Drivers , it mentioned my network card (Internal Intel Corporation PRO/Wireless 3945ABG - using the mac80211 iwl3945 drivers-passed ) as the cards that support wireless in BT5

    do i need to download the driver which is addressed in http://www.aircrack-ng.org/doku.php?id=iwl3945 for my card?

    I also found these errors on syslog and kernellog of BackTrack , i don't know if these logs can make the issue clearer

    Jan 3 14:03:33 root kernel: [ 14.433572] iwl3945 0000:0b:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF
    Jan 3 14:03:33 root kernel: [ 14.455419] iwl3945 0000:0b:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF
    Jan 3 14:03:33 root kernel: [ 14.477205] iwl3945 0000:0b:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF
    Jan 3 14:03:33 root kernel: [ 14.499010] iwl3945 0000:0b:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF
    Jan 3 14:03:33 root kernel: [ 14.520869] iwl3945 0000:0b:00.0: MAC is in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF
    Jan 3 14:03:33 root kernel: [ 14.532726] iwl3945 0000:0b:00.0: bad EEPROM signature,EEPROM_GP=0x00000007
    Jan 3 14:03:33 root kernel: [ 14.532728] iwl3945 0000:0b:00.0: EEPROM not found, EEPROM_GP=0xffffffff
    Jan 3 14:03:33 root kernel: [ 14.532763] iwl3945 0000:0b:00.0: Unable to init EEPROM
    Jan 3 14:03:33 root kernel: [ 14.532789] iwl3945 0000:0b:00.0: PCI INT A disabled
    Jan 3 14:03:33 root kernel: [ 14.532801] iwl3945: probe of 0000:0b:00.0 failed with error -2
    Last edited by sickness; 01-04-2012 at 12:02 PM.

  9. #9
    Just burned his ISO
    Join Date
    Dec 2011
    Posts
    6

    Default Re: Problem With wireless connection in BackTrack 5 R1

    Do you use some kind of virtual machine?

Similar Threads

  1. Wireless Trendnet connection problem
    By pyrodude161 in forum Beginners Forum
    Replies: 0
    Last Post: 05-03-2011, 09:01 PM
  2. Problem with wireless connection
    By brezuicab in forum Beginners Forum
    Replies: 1
    Last Post: 10-10-2010, 07:12 PM
  3. problem with wireless connection
    By mariostavr in forum OLD Wireless
    Replies: 2
    Last Post: 01-27-2010, 04:00 AM
  4. wireless connection problem
    By voochee in forum OLD Newbie Area
    Replies: 1
    Last Post: 06-26-2009, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •