Results 1 to 6 of 6

Thread: Fix for error when building nvidia-current

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    8

    Default Fix for error when building nvidia-current

    When I did:
    apt-get install nvidia-current

    I got the following error:
    Building initial module for 2.6.38

    Code:
    Error! Bad return status for module build on kernel: 2.6.38 (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/nvidia-current/195.36.24/build/ for more information.
    dpkg: error processing nvidia-current (--configure):
     subprocess installed post-installation script returned error exit status 10
    Processing triggers for python-gmenu ...
    Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-2.6.38
    Processing triggers for python-support ...
    Errors were encountered while processing:
     nvidia-current
    When looking in the mentioned make.log it said something about ioctl not found.
    I fixed this by editing the file /usr/src/nvidia-current-195.36.24/nv.c and changing the line:
    Code:
        .ioctl     = nv_kern_ioctl,
    into:
    Code:
         .unlocked_ioctl = nv_kern_unlocked_ioctl,
    Then 'apt-get install nvidia-current' should work.

    If not try:
    dkms build -m nvidia-current -v 195.36.24
    dkms install -m nvidia-current -v 195.36.24
    modprobe nvidia-current

  2. #2
    Member longjidin's Avatar
    Join Date
    Feb 2010
    Location
    Kg Lengkong to Bukit Lada
    Posts
    93

    Default Re: Fix for error when building nvidia-current

    nice job bro....................!!!

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    14

    Default Re: Fix for error when building nvidia-current

    Thank you so much, this worked for me.

  4. #4
    Just burned his ISO erdmaennchen's Avatar
    Join Date
    Jul 2010
    Posts
    15

    Default AW: Fix for error when building nvidia-current

    Works fine! Thanks!

  5. #5
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    4

    Default Re: Fix for error when building nvidia-current

    Thank you very much man,great job!

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Posts
    173

    Default Re: ettercap!!! not on 64 bit!!!

    Installed BT5R1 (64bit) on thinkpad T61 worked nice and fast after installing few things like nvidia drivers etc....ssl strip is indeed installed and in /pentest/web/sslstrip

    ettercap however is a different story, found out after a lot of searching found out it wont work on 64bit!!!!!!
    ip4 lib errors etc
    #ssl dissector error in line 70. uncommented this and error dissapears but still when sniffing the ipv4 errors. So far the only STABLE version is BT4 final, it does it all without any problems and so reliable. for me anyway. BT5r1 looks neat but so many bread and butter tools not working shame really.


    32 bit version gives x-org error upon reboot of drivers for nvdia, worked fine on 64 bit. Framework3/ is now framework/ cant wait for the stable version or the bug fixes to appear.

Similar Threads

  1. ERROR in installing my nvidia driver
    By m0j4h3d in forum Beginners Forum
    Replies: 8
    Last Post: 02-07-2011, 03:00 AM
  2. Error Installing Nvidia BFG GTS 250
    By tktipper in forum OLD BackTrack 4 NON working hardware
    Replies: 1
    Last Post: 10-30-2009, 02:22 PM
  3. /var/log/Xorg.0.log - nvidia GLX error
    By RageLtMan in forum OLD BackTrack 4 (pre) Final
    Replies: 5
    Last Post: 07-10-2009, 02:13 AM
  4. backtrack-nvidia error
    By SWFu64 in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 11
    Last Post: 06-25-2009, 11:30 AM
  5. Help me i have error on building kismet
    By kozer in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-02-2007, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •