Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

  1. #11
    Senior Member
    Join Date
    Jan 2011
    Location
    over the under
    Posts
    197

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    we went over this with you on the last forum you have the version error because before you build cpyrit_calpp you need to edit the line in setup.py... change version 0.4.0 to 0.4.1 to match pyrit. also you if you want to use a second card you need to initialize a second display with amdcccle

    as far as this part
    Traceback (most recent call last):
    File "/usr/local/bin/pyrit", line 6, in <module>
    pyrit_cli.Pyrit_CLI().initFromArgv()
    File "/usr/local/lib/python2.6/dist-packages/pyrit_cli.py", line 117, in initFromArgv
    func(self, **options)
    File "/usr/local/lib/python2.6/dist-packages/pyrit_cli.py", line 159, in new_f
    import cpyrit.pckttools
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/pckttools.py", line 838, in <module>
    class CCMPCrackerThread(CrackerThread, _cpyrit_cpu.CCMPCracker):
    AttributeError: 'module' object has no attribute 'CCMPCracker'

    I don't know what you've gotten yourself into there but someone else will have to help you with that

  2. #12
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    20

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Quote Originally Posted by 2901119 View Post
    we went over this with you on the last forum you have the version error because before you build cpyrit_calpp you need to edit the line in setup.py... change version 0.4.0 to 0.4.1 to match pyrit. also you if you want to use a second card you need to initialize a second display with amdcccle
    ok now I want to remove and reinstalling . How i can
    and how i can install amdcccle it's from synaptic becuse I've installed from synaptic he was problem with my display

    sory me lang and thx 4 Help

  3. #13
    Just burned his ISO
    Join Date
    May 2011
    Posts
    1

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Hey there, Great guide however there is a problem for me on one of the first steps. (its a strange one)

    Quote Originally Posted by jeff2011 View Post
    Also download the AMD-APP-SDK-v2.4-lnx64.tgz (With CAL++ Libraries) from:
    http://developer.amd.com/gpu/AMDAPPS...s/default.aspx
    Untar by typing:
    Code:
    tar -xvzf AMD-APP-SDK-v2.4-lnx64.tgz
    Then go into the directory:
    Code:
    cd AMD-APP-SDK-v2.4-lnx64
    tar -xvzf icd-regisration.tgz
    make install
    everything goes fine until here, upon using the "make install" command, it simply tells me "make: nothing to be done for install"


    All I have done to this os is install to my SSD, install my graphics drivers and attempt this. I just don't see where i am going wrong... I managed to get bt4 running with ati stream and cpyrit fine, also im not afraid of a bit of troubleshooting but this is stumping me since its not giving a hint as to what the problem might be.

    Any hints would be welcomed

  4. #14
    Just burned his ISO
    Join Date
    May 2011
    Posts
    5

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Not sure what the problem is that you're having zakoo, but I'd just try and re-install pyrit and pyrit-cal++ and see what happens. The AMD-APP SDK works just fine if you follow my guide exactly.

    The error you and 2901119 had:
    root@bt:~/pyrit_svn/cpyrit_calpp# ./setup.py build running build running build_ext Building modules... building 'cpyrit._cpyrit_calpp' extension gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/root/AMD-APP-SDK-v2.4-lnx64/include -I/usr/include/python2.6 -c _cpyrit_calpp.cpp -o build/temp.linux-x86_64-2.6/_cpyrit_calpp.o -Wall -fno-strict-aliasing -DVERSION="0.4.0-dev (svn r308)" cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++
    This can be fixed by downloading and install the cal++ libraries from the link listed above and then editing the CMakeLists file and then building and installing cal++. (I added the link to download the cal++ libraries in my guide). This is the way I was able to install amd-app sdk, pyrit & cal++ and I had no problems installing and running it.

  5. #15
    Just burned his ISO
    Join Date
    May 2011
    Posts
    5

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Quote Originally Posted by RandomSquare View Post
    Hey there, Great guide however there is a problem for me on one of the first steps. (its a strange one)



    everything goes fine until here, upon using the "make install" command, it simply tells me "make: nothing to be done for install"


    All I have done to this os is install to my SSD, install my graphics drivers and attempt this. I just don't see where i am going wrong... I managed to get bt4 running with ati stream and cpyrit fine, also im not afraid of a bit of troubleshooting but this is stumping me since its not giving a hint as to what the problem might be.

    Any hints would be welcomed
    Not sure why you're getting that error but I'd say try going back into the directory (in the console) and running:

    make
    make install

    (so just try running the make command by itself first while in the amd app directory and then afterwards run the make install command).
    Hope that works for you, if not then I'm unsure what the issue is.

  6. #16
    Just burned his ISO
    Join Date
    May 2011
    Location
    UK
    Posts
    4

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    I've hit a problem when running make in AMD-APP-SDK-v2.4-lnx64. Everything is looking great up until this point:
    Code:
    make[5]: Entering directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl/app/BoxFilterGL'
    mkdir -p build/debug/x86_64/
    Building build/debug/x86_64//BoxFilterGL.o
    g++  -Wpointer-arith   -Wfloat-equal -g3 -ffor-scope   -I  ../../../../../samples/opencl/SDKUtil/include -I  "/include"  -I  ../../../../../include  -o build/debug/x86_64//BoxFilterGL.o -c  BoxFilterGL.cpp
    In file included from BoxFilterGLSAT.hpp:105,
                     from BoxFilterGL.cpp:93:
    ../../../../../include/GL/glew.h:1138:20: error: GL/glu.h: No such file or directory
    In file included from BoxFilterGLSAT.hpp:107,
                     from BoxFilterGL.cpp:93:
    ../../../../../include/GL/glut.h:62:19: error: GL/gl.h: No such file or directory
    make[5]: *** [build/debug/x86_64//BoxFilterGL.o] Error 1
    make[5]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl/app/BoxFilterGL'
    make[4]: *** [BoxFilterGL] Error 2
    make[4]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl/app'
    make[3]: *** [app] Error 2
    make[3]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl'
    make[2]: *** [cl] Error 2
    make[2]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl'
    make[1]: *** [opencl] Error 2
    make[1]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples'
    make: *** [samples] Error 2
    Looking in the include folder there isn't a glu.h but there is a GLU.h which I copied and renamed glu.h but this didn't work as I then get the following:

    Code:
    In file included from ../../../../../include/GL/glew.h:1138,
                     from BoxFilterGLSAT.hpp:105,
                     from BoxFilterGL.cpp:93:
    ../../../../../include/GL/glu.h:231: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:231: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:231: error: expected initializer before ‘*’ token
    ../../../../../include/GL/glu.h:271: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:271: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:271: error: expected initializer before ‘*’ token
    ../../../../../include/GL/glu.h:354: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:354: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:354: error: expected initializer before ‘*’ token
    ../../../../../include/GL/glu.h:360: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:363: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:364: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:365: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:366: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:367: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:368: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:372: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:373: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:374: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:375: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:376: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:377: error: expected ‘)’ before ‘*’ token
    ../../../../../include/GL/glu.h:384: error: expected ‘)’ before ‘*’ token
    make[5]: *** [build/debug/x86_64//BoxFilterGL.o] Error 1
    make[5]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl/app/BoxFilterGL'
    make[4]: *** [BoxFilterGL] Error 2
    make[4]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl/app'
    make[3]: *** [app] Error 2
    make[3]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl/cl'
    make[2]: *** [cl] Error 2
    make[2]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples/opencl'
    make[1]: *** [opencl] Error 2
    make[1]: Leaving directory `/root/AMD-APP-SDK-v2.4-lnx64/samples'
    make: *** [samples] Error 2
    Can anyone point me in the right direction here please?

  7. #17
    Just burned his ISO
    Join Date
    May 2011
    Posts
    7

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Yea, i can't get this to work either... do you have to run KDE for this to work? cause im running gnome64 and your guide hasnt worked no matter how many times ive tried it, and ive wiped and reinstalled multiple times

  8. #18
    Just burned his ISO
    Join Date
    May 2011
    Posts
    1

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    I have the same problem as above does anyone have a solution

  9. #19
    Member
    Join Date
    Jun 2010
    Posts
    62

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    Add this at the end of /root/.bashrc or in /etc/bash.bashrc

    export AMDAPPSDKROOT=/root/AMD-APP-SDK-v2.4-lnx64
    export AMDAPPSDKSAMPLESROOT=/root/AMD-APP-SDK-v2.4-lnx64/samples
    export LD_LIBRARY_PATH=$AMDAPPSDKROOT/lib/x86_64
    export ATISTREAMSDKROOT=$AMDAPPSDKROOT

    then try some bin in /root/AMD-APP-SDK-v2.4-lnx64//samples/opencl/bin/

    Download cal++ from here
    Code:
    svn co https://calpp.svn.sourceforge.net/svnroot/calpp calpp

    then
    Code:
    cd calpp/trunk
    cmake .
    make
    make install


    Quote Originally Posted by leetbean View Post
    or you can read the error and fix what is wrong.

    Code:
    cal.h: No such file or directory
    calcl.h: No such file or directory
    cal_ext.h: No such file or directory
    edit setup.py in pyrit_svn/cpyrit_calpp and change

    Code:
    CALPP_INC_DIRS.append(os.path.join(CALPP_INC_DIR, 'include'))
    to

    Code:
    CALPP_INC_DIRS.append(os.path.join(CALPP_INC_DIR, 'include/CAL'))
    compile and run....
    Last edited by Freee; 06-01-2011 at 07:46 PM.

  10. #20
    Senior Member
    Join Date
    Jan 2011
    Location
    over the under
    Posts
    197

    Default Re: ATI-APP-SDK + Pyrit + Cal++ How-To Guide (BT5 KDE 64bit)

    hey thanks to leetbean jeff2011 and free, I finally got AMD APP working with pyrit and cal++. now I don't have to use the old version of stream anymore. Thanks guys

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. BT5 KDE 64bit - startx problem
    By fnord0 in forum BackTrack 5 Fixes
    Replies: 60
    Last Post: 12-24-2012, 03:15 PM
  2. BT5 KDE 64bit - Teensy/S.E.T.
    By ColForbin in forum BackTrack 5 Fixes
    Replies: 0
    Last Post: 05-13-2011, 07:19 AM
  3. Replies: 1
    Last Post: 05-11-2011, 05:03 AM
  4. 64bit
    By RageLtMan in forum OLD BackTrack 4 (pre) Final
    Replies: 6
    Last Post: 10-01-2009, 07:52 PM
  5. Error - Wireless Assistant , Guide Guide Guide ....
    By eliv3n in forum OLD Newbie Area
    Replies: 1
    Last Post: 10-08-2007, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •