Results 1 to 2 of 2

Thread: Vmware Fusion 3.1.2 patch for VMware Tools required for use with BT5 VM

  1. #1
    Just burned their ISO
    Join Date
    Apr 2010
    Location
    Los Angeles
    Posts
    17

    Default Vmware Fusion 3.1.2 patch for VMware Tools required for use with BT5 VM

    Installation and configuration of Vmware tools in BT5 under Fusion ver 3.1.2 (latest stable) failed due to make errors.

    (see my post at http://www.backtrack-linux.org/forum...tml#post196793 ) for detailed error messages)

    Turns out the tools need to be patched for kernel 2.6.37 and above (including the 2.6.38 kernel in BT5). The patch and instructions can be found here:

    http://blog.breadncup.com/2011/02/26...rnel-2-6-3738/

    The tools worked after the patch, however I am still struggling with the sound. Upon trying to set the sound preferences in the Gnome desktop I get error message "Waiting for sound system to respond." Also no sound!



    ****UPDATE:
    Sound works fine now. Check out general Gnome audio fix posts from: 2901119 & Sickness

    http://www.backtrack-linux.org/forum...m-respond.html
    http://www.backtrack-linux.org/forum...spond-bug.html
    Last edited by socialcred; 05-16-2011 at 02:42 AM. Reason: update

  2. #2
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    8

    Default Re: Vmware Fusion 3.1.2 patch for VMware Tools required for use with BT5 VM

    Hi SocialCred,

    I was wondering if you could tell me if you had to do anything else, besides those links you provided to get audio working?

    I have a Mac book Pro. running the lastest version of vmware fusion. VMWare tools installs fine, but I can't get audio. I have tried what is suggested in your post, but when I open 'preferences->sounds' Everything in the first tab is greyed out. I've tried playing audio files but I hear nothing....

    any help is very much appreciated.

    Thanks!

Similar Threads

  1. vmware-tools-patch-backtrack4-7.8.5-2_6_29.tar
    By phack in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 10-09-2009, 02:53 AM
  2. vmware tools gzip error from patch
    By alphabit in forum OLD BackTrack 4 General Support
    Replies: 1
    Last Post: 07-06-2009, 03:47 AM
  3. installing vmware-tools in vmware-fusion running bt4-prefinal
    By littlegreendragon in forum OLD BackTrack 4 Howto
    Replies: 5
    Last Post: 06-30-2009, 05:50 PM
  4. [Problem] VMware tools install Guest OS on Vmware Fusion
    By Tharp94895 in forum OLD Newbie Area
    Replies: 1
    Last Post: 06-23-2009, 02:24 PM
  5. BT3 VMWare image suitable for VMWare fusion?
    By Huegel in forum OLD BT3final Support
    Replies: 6
    Last Post: 07-12-2008, 05:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •