The link on http://comax.pagesperso-orange.fr/info/#yamas and the link http://comax.pagesperso-orange.fr/info/mitm/ both point to an old version of the script: VERSION="0.6.9\033[31m-BT5\033[m"

If you download from the update link in the script, http://comax.pagesperso-orange.fr/mitm.sh, then you get the latest version: VERSION="0.7.2\033[31m-BT5\033[m"

It's likely user error due to my lack of knowledge, but I couldn't get the 0.6.9 version to run while the 0.7.2 version ran without issue. With version 0.6.9 it was complaining about an error on line #10 that I couldn't find any problems with.