Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Screen getsblack after startx and Caps lock LED start flashing

  1. #11
    Just burned his ISO
    Join Date
    Nov 2010
    Location
    anywhere
    Posts
    14

    Default Re: Screen getsblack after startx and Caps lock LED start flashing

    i tryed the command before typing ''startx'' just type ''fixvesa'' it will work.good luck.

  2. #12
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    2

    Default Re : Re: Screen getsblack after startx and Caps lock LED start flashing

    Quote Originally Posted by nmiller0113 View Post

    GRUB_CMDLINE_LINUX_DEFAULT=”text splash vga=791 i915.modeset=1″
    For me, it's working...Thank you nmiller0113 !

  3. #13
    Just burned his ISO
    Join Date
    Feb 2012
    Posts
    2

    Default Re: Screen getsblack after startx and Caps lock LED start flashing

    sorry to post after so long, but I am having the same issue after installing Backtrack as the sole operating system on my thinkpad. After installation I can login using root:toor and it gives me the root prompt and the option to type startx to start the gui. I get a solid cursor that never goes away if I type startx. if I attempt to navigate away from root I get "No such file or directory." when I type ls, the only folder I can navigate to is "Desktop" I can't access the hard drive at all to attempt to edit the grub file in that awesome tut that nmiller0113 posted.

    Thank you for all your assistance.

  4. #14
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    1

    Default Re: Screen getsblack after startx and Caps lock LED start flashing

    Lenovo X201 - this worked for me...

    Quote Originally Posted by chiranshu View Post
    finally got the solution

    edit grub menu, delete the word splash and write i915.modeset=1 keep everything as it is....

    then before startx

    rm /root/.kde/cache-root/icon-cache.kcache
    rm /root/.kde/cache-root/plasma_theme_Volatile.kcache
    rm /root/.kde/cache-bt/icon-cache.kcache
    rm /root/.kde/cache-bt/plasma_theme_Volatile.kcache

    and finally backtrack runs on hard disk...

    and then make permanent changes in grub menu after backtrack starts
    go in /etc/default/grub, delete the word splash and write i915.modeset=1

    thats it..
    This worked for me on a Lenovo X201 laptop. I did not have to dump the cache directories, but getting past the blinking caps was a real pain. Thanks for the assist and thanks for the answer!

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Black screen and LED flashing at startx
    By PoloB in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-27-2011, 04:53 PM
  2. Screen Lock - no password works
    By morning_wood in forum BackTrack Bugs
    Replies: 5
    Last Post: 11-14-2010, 09:13 PM
  3. usb mouse and ports stop working after screen lock
    By eyeheartlinux in forum BackTrack Bugs
    Replies: 1
    Last Post: 04-10-2010, 01:36 PM
  4. Can't lock screen under BT4b
    By Dave10 in forum OLD Newbie Area
    Replies: 0
    Last Post: 10-10-2009, 06:17 PM
  5. Scroll, Num, Caps Lock Bug
    By pmarinel in forum OLD BT3final Bugs and Fixes
    Replies: 1
    Last Post: 11-11-2008, 07:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •