Ralink card not supported by Default
ATI radeon 5650 -- Not supported By default

So now the solutions to the problems:-

1.-> Ralink wireless card RT3090
Solution to problems like System Hangs when enabling wireless or wireless card not working.
The problem with this device is that the Drivers installed by default are older of the wireless adapter RT2860 ,which needs to be disabled.
So before installing drivers for RT3090 default drivers must be disabled .


Enter the following Command

lsmod | grep pci

>>List of devices will appear
rt2800pci
rt2800lib
rt2x00pci
rt2x00lib

Now above devices needs to be disabled.So that they dont automatically load up after rebooting.

Now go to directory

cd /etc/modprobe.d

edit the file "blacklist.conf" use the following command

vi blacklist.conf

bt5 will give an ATTENTION message

PRESS E that is edit anyway.


Goto the End of the file and write

blacklist rt2800pci

Save and Quit.

Reboot.

After Rebooting

Check if rt2800pci is disabled or not.

Again Type :- lsmod | grep pci

No device's must be there(Thats in my case)
Just make sure rt2800pci is not there.

Now install drivers
Download Ralink drivers from Ralink's Site:-

http://www.ralinktech.com/support.php?s=2

After Downloading the package:-
Extract it.
in my case it is

2010_1217_RT3090_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO .zip

Extract it:-

unzip 2010_1217_RT3090_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO
(make sure that the directory you unzip is in root)
cd 20101217_RT3090_LinuxSTA_V2.4.0.4_WiFiBTCombo_DPO

Then type following commands


make
make-install
cd /os/linux
insmod rta3090.ko

Drivers are installed.
Open Wicd manager.Go to interfaces change eth0 to ra0.

Default interface name for wireless is ra0.
It is done.
Reboot.

Type ifconfig to see the interfaces.
ra0 is wireless interface.



For ATI card refer to this post it may help :-

http://www.backtrack-linux.org/forum...ck-screen.html