Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: HP DV7 - ATI HD 5650 startx issue (Black screen)

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    May 2011
    Posts
    4

    Default HP DV7 - ATI HD 5650 startx issue (Black screen)

    Hi

    I install backtrack 5 on my hard disc an I have starnge issue.

    firt on boot, I have black screen, don't see terminal, but i made startx to have graphique mode and i install backtrack on my hard disk.

    I install it without any probleme but on firt boot i have blackscreen with startx

    firt I think it's driver issue, I install ATI driver

    Code:
    wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-5-x86.x86_64.run
    sh ati-driver-installer-11-5-x86.x86_64.run
    but still not working......

    any suggestion about this ?

  2. #2
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    12

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    I got the same problem when I try to use the proprietary ATI driver...
    I'm now using the xorg.conf.failsafe, so I can not use the full resolution of my display
    You could uninstall fglrx and then do the following command:

    cp /etc/X11/xorg.conf.failsafe /etc/X11/xorg.conf

    It worked for me.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    5

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    Quote Originally Posted by mbooma View Post
    Hi

    I install backtrack 5 on my hard disc an I have starnge issue.

    firt on boot, I have black screen, don't see terminal, but i made startx to have graphique mode and i install backtrack on my hard disk.



    I install it without any probleme but on firt boot i have blackscreen with startx

    firt I think it's driver issue, I install ATI driver

    Code:
    wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-5-x86.x86_64.run
    sh ati-driver-installer-11-5-x86.x86_64.run
    but still not working......

    any suggestion about this ?
    Code:
    chmod +x ati-driver-installer-11-5-x86.x86_64.run
    ./ati-driver-installer-11-5-x86.x86_64.run
    Follow the installer wizard.
    reboot

    when it comes back up run the following from the console:
    Code:
    aticonfig --initial
    then run:
    Code:
    startx
    Should come up fine after that using the ATI driver.

  4. #4
    Just burned his ISO
    Join Date
    Sep 2009
    Posts
    6

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    Hello, i have install ati-driver-installer-11-5-x86.x86_64.run driver succesfully, and run aticonfig --initial after, and reboot, but Xorg at the start get some error:

    Code:
    (EE) No supported AMD display adapters were found
    (EE) No devices detected.
    
    Fatal server error:
    no screens found
    I have an HP DM1Z ATI radeon HD6310M.

    Thanks you

  5. #5
    Just burned his ISO
    Join Date
    May 2011
    Posts
    9

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    I want to emphasize that you set your card to run in discrete mode BEFORE you reboot if you have a dual mode gfx card, otherwise you'll keep getting "no screens found" error, in which case you just boot in recovery mode, reset graphics to failsafe and run the commands again.

  6. #6
    Just burned his ISO
    Join Date
    Aug 2009
    Posts
    5

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    I posted a reply with the procedure I used but for some reason it won't come up.

  7. #7
    Just burned his ISO
    Join Date
    May 2011
    Posts
    4

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    I will try new installation now

    I tried i915.modset=1 but not working for me...

  8. #8
    Just burned his ISO aBsolutex3's Avatar
    Join Date
    Jan 2010
    Location
    Here
    Posts
    2

    Angry Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    yea im having the same problem i tried bt5 gnome 32bit on my dv7 and nv53 bith with ati graphics and its just not working

  9. #9
    Just burned his ISO
    Join Date
    May 2011
    Posts
    1

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    Here's another thing to try:

    edit your grub boot parameters and add
    Code:
    radeon.modeset=0
    to the end of your linux boot line. If this is the same issue that I'm seeing on Ubuntu's Natty (11.04), it's a race-condition in the driver for handling run-time switching of the graphics cards.

  10. #10
    Just burned his ISO
    Join Date
    May 2011
    Posts
    3

    Default Re: HP DV7 - ATI HD 5650 startx issue (Black screen)

    Quote Originally Posted by morphiend View Post
    Here's another thing to try:

    edit your grub boot parameters and add
    Code:
    radeon.modeset=0
    to the end of your linux boot line. If this is the same issue that I'm seeing on Ubuntu's Natty (11.04), it's a race-condition in the driver for handling run-time switching of the graphics cards.
    yay I get to the shell now with my MSI EX610 notebook with ATI HD2400 now

    Edit:

    but startx still fails back to shell -.-

    Solution that works atleast for MSI notebook with ATI HD2400 on KDE x64:

    edit grub parameters and add:
    radeon.modeset=0

    Remove .kcache files in:
    /root/.kde/cache-bt (2 files)
    /root/.kde/cache-root (2 files)
    and startx again

    I hope there will be another release of BT5 without these "hacks" needed to boot the LiveCD... the BT4 LiveCD works without any problems...
    Last edited by sickness; 05-30-2011 at 07:59 AM. Reason: Merged.

Page 1 of 2 12 LastLast

Similar Threads

  1. Black Screen after Hard Disk Install and "startx"
    By Nile13 in forum BackTrack 5 Bugs
    Replies: 70
    Last Post: 01-22-2013, 07:13 PM
  2. Black screen and LED flashing at startx
    By PoloB in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-27-2011, 04:53 PM
  3. Replies: 5
    Last Post: 01-20-2011, 02:53 AM
  4. compiz, nvidia, Black screen issue
    By BigMac in forum OLD Newbie Area
    Replies: 2
    Last Post: 08-18-2009, 07:21 AM
  5. Screen goes black after writing startx
    By xaerg in forum OLD LiveCD Support
    Replies: 5
    Last Post: 01-11-2008, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •