Results 1 to 9 of 9

Thread: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

  1. #1
    Junior Member dangerousgangsta's Avatar
    Join Date
    Jul 2008
    Posts
    29

    Default RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    So I have a Samsung N210 notebook with the following:

    RTL8187 Chipset
    Driver R8187
    Release: BackTrack 5 R1

    As far as I can remember, I dont think monitor mode was supported for my chipset on BT4, but seems to work on BT 5 R1. (airmon-ng start wlan0 - monitor mode enabled)

    So I can enable monitor mode. But when I run airodump-ng on wlan0 (my interface) I get no AP's or stations whatsoever.

    When I do the aireplay-ng -9 wlan0 injection test I get:

    Trying broadcast probe requests...
    No Answer
    Found 0 APs.
    Can anyone enlighten me as to why I can enable monitor mode but get nothing from airodump or aireplay injection test?
    I've looked across the forum but didn't find anything that would answer my question.

    Thanks.

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    Have you checked if the channel your interface is listening to is the same channel as your AP?

  3. #3
    Junior Member dangerousgangsta's Avatar
    Join Date
    Jul 2008
    Posts
    29

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    Yes Snayler.

    I have done a specific scan on channel 5 which is the channel my AP uses. But yet I get nothing. It seems as though the RTL8187 chipset is able to go into monitor mode but the drivers are still not good enough for injection.

    Its one step ahead in the right direction, atleast my card can go into monitor mode with the introduction of BT5. Appreciate all the work of the creators and developers. Hopefully a future update and release may rectify my issue.

    Unless someone else has any suggestions, I'll be going ahead anyway to do a permanent install of BT5.

  4. #4
    Just burned his ISO
    Join Date
    Dec 2011
    Posts
    2

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    dangousgangstar i am having the same problem as you, i have a netbook samsung np n130 the same type of drivers as you i think... when i run the command
    aireplay-ng -9 wlan0
    i get no answer, no ap. if you solve the problem or if anyone know how to solve the problem please let me know how to solve this problem.

  5. #5
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    RTL8187L (Found on ALFA AWUS036H) is fully supported, but there are also RTL8187B and RTL8187SE.

    RTL8187B supports monitor mode but i rarely managed to get injection working on BT4. Haven't tested on BT5 because I don't have the card anymore.

    As for RTL8187SE, I found on my quick research that people report it to support monitor mode, but not injection.

    I guess it's only a matter of finding out which exact chipset you have.

  6. #6
    Junior Member dangerousgangsta's Avatar
    Join Date
    Jul 2008
    Posts
    29

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    Alright, this is going to sound silly, but I just realised that going with what BT5 has told me is wrong. BT5 reports that I have RTL8187.

    However under Windows 7 (currently installed on this netbook) it says I have RTL8192E under network adapters.

    The thread here clears that up aswell.

    http://www.backtrack-linux.org/forum...ad.php?t=40309

    I am looking forward checking the above out. But I have run into a problem. I have successfully installed Backtrack on my netbook but I have no GRUB menu whatsoever and it keeps booting into Windows 7, the installation for BT5 was successful. I know this is off topic but I dont think i'll be able to carry out the steps in the thread until I'm able to load BT5 off my HDD. Any ideas?

  7. #7
    Just burned his ISO
    Join Date
    Dec 2011
    Posts
    2

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    hey dangerousgangstar I am wondering if you got back track 5 to work on your netbook...and if you did can you tell me step by step the commands
    you use to get it to work..and the link you have up when i clicked it..it was a dead link..
    thanks brother.

  8. #8
    Junior Member dangerousgangsta's Avatar
    Join Date
    Jul 2008
    Posts
    29

    Default Re: RTL8187 Chipset - Airmon-ng No AP's + injection test fail

    I was interested in what this users input would be as I posted here:

    http://www.backtrack-linux.org/forum...ad.php?t=40309

    But have no reply yet, was still not determined to give it up, so after several hours of working on this. Turns out I can install the RTL8187 drivers for my netbook, it does support monitor mode on wlan0 interface but DOES NOT support injection, yet.

    To download it is simple:

    Code:
    http://people.debian.org/~benh/rtl-wlan/
    Download the appropriate RTL8192 driver for your machine.

    Extract it to root. Either by

    tar -xzvf name-of-file.tar.gz

    then:

    make

    make install

    then reboot.

    If your given an error abit /lib/modules 2.xx then do a quick google for it or ask on this thread. I cant seem to remember what the solution for that error was.

    This is for the RTL8192E chipset and not the RTL8187. The reason I named this thread RTL8187 is because BT5 reported that this was the driver being used for my chipset, which was wrong.

  9. #9
    Just burned his ISO
    Join Date
    Dec 2011
    Posts
    2

    Default Airmon-ng No AP's

    Hi, same issue

    I have installed BT 5 on Vmware player latest version with Digicom DUSB 110N successfully.

    Airmon-ng shows: Interface: wlan0 Chipshet: Ralink RT2870/3070 driver:rt2800usb

    As I have gone step by step for cracking wep/wpa but airodump-ng <mon0> doesnot show wifi AP not any one

    my step for wep:

    1. airmon-ng
    (it shows wlan0 as interface)
    2. airmon-ng stop wlan0
    3. ifconfig wlan0 down
    4. macchanger --mac fake mac wlan0
    5. airmon-ng start wlan0
    (monitor mode enabled on mon0)
    6. airmon-ng wlan0 up
    7.airodump-ng mon0

    (No AP shown though supposed to show the AP)

    Note: tried the steps many though doesn't work

    tried with aireplay-ng -9 wlan0
    (no AP)

    Hope to response prompt.


    Thanks

Similar Threads

  1. airmon-ng does not display any interface,chipset or driver
    By trouble18 in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 09-10-2011, 01:20 PM
  2. wlan0/eth0/network/dhcp Fail Fail Fail
    By DavidOfLondon in forum Beginners Forum
    Replies: 3
    Last Post: 09-01-2010, 08:51 AM
  3. chipset rtl8187 for a kind of Newbie
    By kitcat in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-09-2009, 03:59 AM
  4. Alpha Network AWUS036H rtl8187 chipset in managed mode
    By timstewart in forum OLD BackTrack v2.0 Final
    Replies: 8
    Last Post: 06-13-2008, 10:50 AM
  5. rtl8187 driver authors had full access to chipset specs?
    By sergeikolomov in forum OLD Wireless
    Replies: 2
    Last Post: 02-01-2008, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •