dlink adapter wich use builted in drivers seems to need two more command before try to set monitor mode, without even if you success in putting card into monitor, card will not be able to inject...........

iwpriv rausb0 forceprism 1 #Enable prism headers (to show power levels in airodump-ng)

iwpriv rausb0 rfmontx 1 #allow transmission in monitor mode (enables aireplay-ng attacks)

iwconfig rausb0 mode monitor #
airmon-ng start rausb0 #Put the card into monitor mode