Results 1 to 5 of 5

Thread: autoconf.h

  1. #1

    Default autoconf.h

    Hi,
    I'm trying to make my wireless driver.
    It's the I'm getting the driver from: http://www.broadcom.com/docs/linux_s...0_82_38.tar.gz

    Well, my problem happens when I'm do the "make" to build the driver.

    The error is that "autoconf.h" was not found.

    I've already install the linux source and headers.

    What else do I need ?!
    []'s
    Hack the planet, Save the world.

  2. #2
    Senior Member ghostdog67's Avatar
    Join Date
    Sep 2008
    Posts
    180

    Default Re: autoconf.h

    Hi, the correct way to get Broadcom drivers to work on BT5 is the following:

    1. Download the Broadcom drivers: http://www.broadcom.com/support/802.11/linux_sta.php
    2. Unpack and modify the ‘src/wl/sys/wl_linux.c‘:
    Line 35 (after #include <linux/etherdevice.h>) add:

    #include < linux/sched.h >

    3. Compile the code with: make
    4. Copy the new driver: sudo mv wl.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
    5. Update dependencies: sudo depmod -a
    6. Modify the blacklist to include the ‘b43′ and ’ssb’ drivers /etc/modprobe.d/blacklist.conf (Add below the bcm43xx blacklist)

    The part above you probably have seen a few times while googling for the answer. But there is a small problem, as you would have noticed, the ‘ssb‘ driver cannot be blacklisted. It is included in the initrd as I remember from the ubuntuforums. To solve this issue modify the /etc/rc.local to include before the exit(0):

    Code:

    rmmod ssb
    modprobe wl

    Now on startup the ssb gets removed and after that the new wl gets inserted. Adding wl to the /etc/modules will not help because the removing needs to be done first.
    So with the /etc/rc.local modification everything happens in the correct order for perfect WiFi.

    This was tested multiple times on a MacBook Pro with the Broadcom 4328 chipset and should work for all chipsets not supported by the b43 drivers.

    Update:
    Not all systems include the 'linux/sched.h' file. Install the 'linux-headers-generic' package if you get errors. The generic package is a meta package that should install the propper package for your kernel. If it isn't working install with
    Code:

    sudo apt-get install linux-headers-$(uname -r)

    Good Luck
    GD

  3. #3

    Default Re: autoconf.h

    Didn't work:

    root@bt:/opt/drivers/wireless# make
    KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
    make[1]: Entering directory `/usr/src/linux-source-2.6.38'

    WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers
    is missing; modules will have no dependencies and modversions.

    LD /opt/drivers/wireless/built-in.o
    CC [M] /opt/drivers/wireless/src/shared/linux_osl.o
    CC [M] /opt/drivers/wireless/src/wl/sys/wl_linux.o
    /opt/drivers/wireless/src/wl/sys/wl_linux.c: In function ‘wl_attach’:
    /opt/drivers/wireless/src/wl/sys/wl_linux.c:485: error: implicit declaration of function ‘init_MUTEX’
    make[2]: *** [/opt/drivers/wireless/src/wl/sys/wl_linux.o] Error 1
    make[1]: *** [_module_/opt/drivers/wireless] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.38'
    make: *** [all] Error 2


    And I've installed the headers:

    root@bt:/opt/drivers/wireless# aptitude search linux-headers-$(uname -r)
    i linux-headers-2.6.38 - Header files related to Linux kernel, specifically,


    Well, If anyone knows anything about this, I appreciate the help.
    []'s
    Hack the planet, Save the world.

  4. #4
    Just burned his ISO
    Join Date
    May 2011
    Posts
    7

    Default Re: autoconf.h

    Make worked for me after changing line 485 in src/wl/sys/wl_linux.c from
    Code:
    init_MUTEX(&wl->sem);
    to
    Code:
    sema_init(&wl->sem, 1);
    I found this solution at: http://bugs.gentoo.org/350196

  5. #5

    Default Respuesta: autoconf.h

    Hi @Astrobyte,

    I've done what did you say. But didn't work, look:

    Output when I load the module: ( #insmod wl.ko )
    # tail -f /var/log/messages

    May 21 16:50:25 bt kernel: [ 890.725184] wl 0000:04:00.0: PCI INT A -> Link[LK4E] -> GSI 22 (level, low) -> IRQ 22
    May 21 16:50:25 bt kernel: [ 890.746548] eth1: Broadcom BCM4315 802.11 Hybrid Wireless Controller 5.100.82.38
    I didn't see an error in that. Moving on:

    # ifconfig -a

    eth0 Link encap:Ethernet HWaddr 00:1d:72:47:ed:f3
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:42

    eth1 Link encap:Ethernet HWaddr 00:1a:73:ed:8f:32
    inet6 addr: fe80::21a:73ff:feed:8f32/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:22

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:149 errors:0 dropped:0 overruns:0 frame:0
    TX packets:149 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:18305 (18.3 KB) TX bytes:18305 (18.3 KB)
    # iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Bit Rate:54 Mb/s Tx-Powerff
    Retry min limit:7 RTS thrff Fragment thrff
    Power Managementmode:All packets received
    Link Quality=5/5 Signal level=0 dBm Noise level=0 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    As you can see, the wireless interface seems work, but the light of my wireless remains red, which means the wireless didn't actually turn on.

    I've had unload b43, ssb and the wl that came with the distribution.

    I'm doing something wrong ? or what ?

    Thanks for the help.
    []'s
    Hack the planet, Save the world.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •