Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: BT5 + Metasploit + PostgreSQL

  1. #31
    Junior Member
    Join Date
    Dec 2008
    Posts
    31

    Default Re: BT5 + Metasploit + PostgreSQL

    Is the .rc file just simply a text document with a .rc extention? The file's properties dialog box shows it as a plain text document. I just wanted to verify I'm not doing things wrong.
    RIP SHIRLEY 10/11/2008

  2. #32
    Just burned his ISO
    Join Date
    Oct 2011
    Posts
    1

    Default Re: BT5 + Metasploit + PostgreSQL

    Thank you very much for the tutorial.

    I'm trying to use the the in-built postgresql and what I get is:


    Code:
    Error while running command db_connect: Failed to connect to the database: could not connect to server: Connection refused
    	Is the server running on host "127.0.0.1" and accepting
    	TCP/IP connections on port 5432?
    
    
    Call stack:
    /opt/framework/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1903:in `db_connect_postgresql'
    /opt/framework/msf3/lib/msf/ui/console/command_dispatcher/db.rb:1711:in `cmd_db_connect'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:376:in `run_command'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:338:in `block in run_single'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:332:in `each'
    /opt/framework/msf3/lib/rex/ui/text/dispatcher_shell.rb:332:in `run_single'
    /opt/framework/msf3/lib/rex/ui/text/shell.rb:199:in `run'
    /opt/framework/msf3/msfconsole:130:in `<main>'

    What is this noob doing wrong?

    Thank you in advance

  3. #33
    Member
    Join Date
    Apr 2010
    Posts
    51

    Default Re: BT5 + Metasploit + PostgreSQL

    I've installed and configured succesfully (I hope that) postgresql in msf. I can db_import ok but when I'm trying to execute db_hosts command it says:

    [-] Unknown command: db_hosts.
    msf >

    The same result I get when I'm trying the db_destroy command. Why is happening ?

    Thanks in advance for any help!!!

    Edit: The command renamed to: hosts? or I am blind? :P
    Last edited by khaos; 10-29-2011 at 10:27 AM.

  4. #34
    Just burned his ISO
    Join Date
    Dec 2011
    Posts
    4

    Default Re: BT5 + Metasploit + PostgreSQL

    db_autopwn
    UnKnow command:

    somedoby help?
    here backtrack 5 r1 or backtrack5 same problem...

  5. #35
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

  6. #36
    Just burned his ISO
    Join Date
    Mar 2012
    Location
    Philippines
    Posts
    3

    Default Re: BT5 + Metasploit + PostgreSQL

    Please help. I am trying to connect to posgresql database. I am using BackTrackKDE 5 R2 Below are the commands that I used:

    apt-get install postgresql libpq-dev
    sudo su postgres -c psql
    ALTER USER postgres WITH PASSWORD 'novirus';
    \q
    sudo passwd -d postgres
    sudo su postgres -c passwd
    update-alternatives --config ruby
    choose 0 for "auto-mode"
    gem install pg
    msfconsole
    db_driver postgresql
    db_connect postgres:novirus@127.0.0.1/metasploit (“metasploit” being the name of the database)

    But I am getting the error " Error while running command db_connect: Failed to connect to the database: FATAL: password authentication failed for user "postgres"

    I used the same commands with Bactrack 5 R2 GNOME and it works fine.

  7. #37
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: BT5 + Metasploit + PostgreSQL

    Quote Originally Posted by silverstri View Post
    Please help. I am trying to connect to posgresql database. I am using BackTrackKDE 5 R2 Below are the commands that I used:

    apt-get install postgresql libpq-dev
    sudo su postgres -c psql
    ALTER USER postgres WITH PASSWORD 'novirus';
    \q
    sudo passwd -d postgres
    sudo su postgres -c passwd
    update-alternatives --config ruby
    choose 0 for "auto-mode"
    gem install pg
    msfconsole
    db_driver postgresql
    db_connect postgres:novirus@127.0.0.1/metasploit (“metasploit” being the name of the database)

    But I am getting the error " Error while running command db_connect: Failed to connect to the database: FATAL: password authentication failed for user "postgres"

    I used the same commands with Bactrack 5 R2 GNOME and it works fine.
    Metasploit comes with it's own postgresql server now, so you don't need the configuration anymore.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Page 4 of 4 FirstFirst ... 234

Similar Threads

  1. Metasploit db_autopwn using PostgreSQL
    By sickness in forum BackTrack Howtos
    Replies: 53
    Last Post: 03-28-2011, 03:22 AM
  2. [Video] Metasploitable - PostgreSQL
    By g0tmi1k in forum BackTrack Videos
    Replies: 0
    Last Post: 07-01-2010, 01:22 PM
  3. Nexpose Postgresql error
    By WolverineOD in forum Beginners Forum
    Replies: 1
    Last Post: 05-02-2010, 04:45 PM
  4. errore: postgresql-8.3
    By xanders in forum Supporto Software
    Replies: 10
    Last Post: 11-21-2009, 09:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •