Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 71

Thread: Black Screen after Hard Disk Install and "startx"

  1. #51
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    15

    Default AW: Black Screen after Hard Disk Install and "startx"

    quiet splash i915.modeset=1 vga=791
    Does work fine on my Acer 5742G with the 32bit KDE
    Thx for that

  2. #52
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: Black Screen after Hard Disk Install and "startx"

    no doubt this will work for you, it did for me!
    print this out and type it in after your user name and password

    rm /root/.kde/cache-root/icon-cache.kcache
    rm /root/.kde/cache-root/plasma_theme_Volatile.kcache
    rm /root/.kde/cache-bt/icon-cache.kcache
    rm /root/.kde/cache-bt/plasma_theme_Volatile.kcache
    startx


    voila!

  3. #53
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    1

    Default Re: Black Screen after Hard Disk Install and "startx"

    Hello,

    Excuse me for my English, I'm French and I'm not sure that all I say will be comprehensible.

    So I explain my issue.

    I have install BT5 on my Eeepc in dual boot with Windows XP.
    The install was correctly done despite blackscreen when booting Live CD. I fix that with the command line "i915.modeset=1" and now BT work perfectly.
    But when I launch Windows XP, I have a black screen. The system boot because I can see the loading bar and I hear the starting sound.

    If someone can Help me, please.

    Also, Here my grub.conf file. I try to edit the custom entry but without success.

    PHP Code:
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by /usr/sbin/grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #

    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      load_env
    fi
    set 
    default="0"
    if [ ${prev_saved_entry} ]; then
      set saved_entry
    =${prev_saved_entry}
      
    save_env saved_entry
      set prev_saved_entry
    =
      
    save_env prev_saved_entry
      set boot_once
    =true
    fi

    function savedefault {
      if [ -
    ${boot_once} ]; then
        saved_entry
    =${chosen}
        
    save_env saved_entry
      fi
    }

    function 
    recordfail {
      
    set recordfail=1
      
    if [ -${have_grubenv} ]; then if [ -${boot_once} ]; then save_env recordfailfifi
    }
    insmod ext2
    set root
    ='(hd1,6)'
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
    if loadfont /usr/share/grub/unicode.pf2 then
      set gfxmode
    =1024x768
      set gfxpayload
    =keep
      insmod gfxterm
      insmod vbe
      
    if terminal_output gfxterm then true ; else
        
    # For backward compatibility with versions of terminal.mod that don't
        # understand terminal_output
        
    terminal gfxterm
      fi
    fi
    insmod ext2
    set root
    ='(hd1,6)'
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
    set locale_dir
    =($root)/boot/grub/locale
    set lang
    =en
    insmod gettext
    if [ ${recordfail} = ]; then
      set timeout
    =-1
    else
      
    set timeout=10
    fi
    ### END /etc/grub.d/00_header ###

    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight
    =black/light-gray
    ### END /etc/grub.d/05_debian_theme ###

    ### BEGIN /etc/grub.d/10_linux ###
    menuentry 'Ubuntu, with Linux 2.6.38' --class ubuntu --class gnu-linux --class gnu --class os {
            
    recordfail
            insmod ext2
            set root
    ='(hd1,6)'
            
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
            linux   
    /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro   text splash nomodeset vga=791
            initrd  
    /boot/initrd.img-2.6.38
    }
    menuentry 'Ubuntu, with Linux 2.6.38 (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
            
    recordfail
            insmod ext2
            set root
    ='(hd1,6)'
            
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
            
    echo    'Loading Linux 2.6.38 ...'
            
    linux   /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro single 
            
    echo    'Loading initial ramdisk ...'
            
    initrd  /boot/initrd.img-2.6.38
    }
    ### END /etc/grub.d/10_linux ###

    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
            
    insmod ext2
            set root
    ='(hd1,6)'
            
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
            linux16 
    /boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
            
    insmod ext2
            set root
    ='(hd1,6)'
            
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
            linux16 
    /boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###

    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry "Windows NT/2000/XP (on /dev/sda1)" {
            
    insmod ntfs
            set root
    ='(hd0,1)'
            
    search --no-floppy --fs-uuid --set D004352F04351A44
            drivemap 
    -(hd0) ${root}
            
    chainloader +1
    }
    ### END /etc/grub.d/30_os-prober ###

    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    menuentry "Windows NT/2000/XP (on /dev/sda1)" {
            
    insmod ntfs
            set root
    ='(hd0,1)'
            
    search --no-floppy --fs-uuid --set D004352F04351A44 vga=791
            drivemap 
    -(hd0) ${root}
            
    i915.modeset=1
            chainloader 
    +1
    }


    ### END /etc/grub.d/40_custom ### 

  4. #54
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    4

    Default Re: Black Screen after Hard Disk Install and "startx"

    Hi Everyone,

    I'm having the same issue,

    I can't proceed with the installation process. i can't even go to the 'Install BackTrack" portion. I'm stuck at the "root@root:~#" and every time i type startx the screen goes black and capslock keep flashing. I have tried editing the grub but I can't grup-update since it is in the Live CD.

    I'm using MSI FX400x-i3885 with 2 GPUs, intel core i3. Tried both KDE and GNOME 64bit but same problem. I have posted my concern http://www.backtrack-linux.org/forum...00x-i3885.html but none is replying yet.

    what should i do? anyone please,



    thanks in advance.
    jsof

  5. #55
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    6

    Default Re: Black Screen after Hard Disk Install and "startx"

    I had similar problems with such a black screen whenever I logged out and when I tried to sudo startx on an account that couldn't sudo.

    I installed the driver for my video card (ATI Mobility Radeon HD 5700) and it works perfectly now.

  6. #56
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    13

    Default Re: Black Screen after Hard Disk Install and "startx"

    ok so for those of you guys that have issues with launch startx and x-windows crashing try this:

    cd /root/.kde/
    find . -type f -iname "*.kcache" -delete
    startx

    For the guys that cant even see the console after booting and they just get a blank screen try this:

    when the grub boot screen comes up hit "e" for edit mode
    and you should see something similar to this (note this will vary):

    recordfail
    insmod ext2
    set root='(hd1,6)'
    search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
    linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro text splash nomodeset vga=791
    initrd /boot/initrd.img-2.6.38

    The line to be concerned with here is the:

    linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro text splash nomodeset vga=791

    change it to look like this at the end:

    linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro quiet splash i915.modeset=1 vga=791

    you are just changing "text" to "quiet" and "nomodset" to "i915.modset.modeset=1"

    then hit ctrl-x to boot

    See if that works. If so you can make the changes permanent by editing /etc/default/grub file with the changes above.
    Change:
    GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"
    to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"

    Then at a terminal type:
    update-grub

    reboot and see your new display.

  7. #57
    Just burned his ISO
    Join Date
    Jul 2011
    Posts
    1

    Cool <SOLVED TO ME>Re: Black Screen after Hard Disk Install and "startx"

    Hi friends...

    at first... sorry by my english... i'm a brazillian one...

    Ok... i've tried each topic of this forum...

    I have a DELL VOSTRO 3300 with Intel Graphics card i915.

    I'm using BT5 64bits with GNOME. To solve my problem was very simple... i just removed every thing between the quotes ("") in the line "GRUB_CMDLINE_LINUX_DEFAULT"... I know... it's strange... but it's working right now... i'll attach here a copy of my /etc/default/grub file...

    PLEASE!!! DON'T FORGET TO RECOMPILE THE GRUP AFTER CHANGE THE GRUB FILE... do this with the command "update-grup"

    follow the grub file...

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT=""
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1366x768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    1,1 Top


    I really hope to help...
    please... make contact with e-mails... I'm starting with BT... and hope to share some knowledge!!!

  8. #58
    Just burned his ISO
    Join Date
    Nov 2010
    Location
    anywhere
    Posts
    14

    Default Re: Black Screen after Hard Disk Install and "startx"

    hey guys i solved the 1st problem of no csreen found simply by typing ''fixvesa'' befor the ''startx'' it will boot normal but i have another problem now it's the wifi ( i'm booting from usb ) so the wifi on my laptop Dell inspiron n5010 core i3 had the Broadcom with bluetooth integrated so back to the problem that backtrack only show that i have lan but no wifi on my laptop.any help would be apreciated

  9. #59
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Re: Black Screen after Hard Disk Install and "startx"

    This solved the problem for me (BT5 Gnome 32bit on HP ELiteBook 8440p, NVIDIA NVS 3100 graphics with 512 MB dedicated gDDR3 video memory
    Intel® HD Graphics):

    GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"
    to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=792"

    Then at a terminal type:
    update-grub

  10. #60
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    2

    Default Re: Black Screen after Hard Disk Install and "startx"

    Quote Originally Posted by snipes420 View Post
    I am having a similar problem.
    Acer Travelmate 5742
    Intel HD Graphics

    The 64-bit gnome Live DVD booted fine to the X environment.
    I installed it to my hard drive. No errors.
    Rebooted after to the default boot item and it booted up to a console login.
    Login and try to 'startx'
    The screen goes black and nothing happens.
    Trying to press ctrl+alt+FX buttons doesn't switch to text virtual terminals. the system doesn't respond even to pressing the power button to initiate a power off. After a hard power off (hold the power botton) there is nothing in the /var/log/Xorg.0.log (file is 0 bytes).
    Previous posters in this thread recommend installing proprietary drivers but this machine being Intel Graphics I am not able to do that.
    I am thinking since the Live environment worked I will start there to track down a working configuration.

    i have the same problem.
    i got a hp 206la
    intel hd graphics

    i tried to run the gnome 64 bit version.

Page 6 of 8 FirstFirst ... 45678 LastLast

Similar Threads

  1. Replies: 10
    Last Post: 12-12-2010, 02:58 PM
  2. White screen after running "startx"
    By emximer in forum Beginners Forum
    Replies: 1
    Last Post: 04-30-2010, 08:41 PM
  3. Replies: 2
    Last Post: 03-02-2009, 01:52 AM
  4. change screen resolution before using "startx" command?
    By Unit1 in forum OLD BT3final Support
    Replies: 1
    Last Post: 02-03-2009, 10:53 AM
  5. "loading the desktop" --> black screen
    By jv_guano in forum OLD Newbie Area
    Replies: 3
    Last Post: 11-27-2007, 12:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •