Hello everybody!

My notebook is ASUS A53XI241SV,there art two Graphics,the one is Intel's and the other one is nVidia GeForce GT540M. I installed the nVidia drivers same as http://www.backtrack-linux.org/forum...deo-cards.html.

But when i type startx there have some error:
Code:
X: warning; process set to priority -1 instead of requested priority 0

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux bt 2.6.35.8 #1 SMP Sun Nov 14 06:32:36 EST 2010 i686
Build Date: 09 March 2009  10:48:54AM
xorg-server 2:1.5.2-2ubuntu3.1 (buildd@rothera.buildd) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 10 13:51:29 2011
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "type1" (module does not exist, 0)
(EE) No devices detected.

Fatal server error:
no screens found
giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
then i tried use apt-get install nvidia-drivers(before this i'm executed apt-get update&apt-get upgrade&apt-get dist-upgrade) to install my nvidia driver,but there have a error too:

Code:
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package nvidia-drivers
At last I found a problem with my nVidia,when i use "lspci | grep VGA" command,there output two devices:

Code:
00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)
you can see in the nVidia line,there are not have my nvidia devices Series.

What's wrong with my nVidia?
Who can help me?
In this case,How to install the nVidia Drivers?

plz help me!! Thanx!!