Results 1 to 4 of 4

Thread: D-Link-122: Problems to get IP an netmask

  1. #1
    Just burned his ISO
    Join Date
    May 2007
    Posts
    2

    Default D-Link-122: Problems to get IP an netmask

    Hello!

    I've just installed BT2 on my hd and everything worked quite well.
    I's able to create new user-accounts, handle sudo and everyting else.
    Only one thing didn't work the way it should have: The WLAN.

    I got a D-Link-122 USB Stick which is detected correctly and which is
    known as rausb0 in iwconfig. Running the Wirelessassistant-Tool I's
    able to set the rigth key, the ESSID, accespoint and so on, but I couldn't
    get a local IP, gateway and netmask. I tried dhcpcd and setting those things
    manually, but it didn't help.
    I can't send a ping to google and KWifiManager tells me, that everything is
    correct, but a local IP is unavaible.

    What shall I do? I hope you can help me!

    Yours,
    d347h

    ps: I'm sorry about my bad English, but I'm from Germany...

  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    i got 122 c1 run fine...

    ifconfig rausb0 down
    after commit changes like routing and so on
    ifconfig rausb0 up
    dhcpcd -n rausb0

    each time i do that no pb...it's can also inject well
    you can verifiy it with :
    ifconfig rausb0 up
    airmon-ng start rausb0
    aireplay-ng -9 rausb0
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Just burned his ISO
    Join Date
    May 2007
    Posts
    2

    Default

    Hello!

    I gave my best but I still have the same problems.
    Here are the error/messages wlassistant gives:
    (I've hidden the name of my ESSID and my key with "x"s!)
    Code:
    Loaded application options.
    DHCP Client: dhcpcd
    All executables found.
    iwconfig_status: /sbin/iwconfig
    ==>stderr: lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    Wireless interface(s): rausb0
    Permissions checked.
    ifconfig_status: /sbin/ifconfig rausb0
    scan: /sbin/iwlist rausb0 scan
    Networks found: 4
    Checking for active connection.
    Trying to get gateway address...
    ...from 'route'
    No default gateway.
    ACTION: CONNECT.
    kill_dhcp: /sbin/dhcpcd -k rausb0
    ==>stderr: ****  /sbin/dhcpcd: not running
    ifup: /sbin/ifconfig rausb0 up
    iwconfig_set: /sbin/iwconfig rausb0 mode managed channel 12 key open s:xxxxxxxxxxxxxxxxxxxxxxxxxx essid XXXXX
    ==>stderr: Error for wireless request "Set Encode" (8B2A) :
        SET failed on device rausb0 ; Invalid argument.
    iwconfig_ap: /sbin/iwconfig rausb0 ap 00:18:4D:19:95:16
    ifconfig_dhcp: /sbin/dhcpcd -nd rausb0
    kill_dhcp: /sbin/dhcpcd -k rausb0
    ==>stderr: ****  /sbin/dhcpcd: not running
    CONNECTION FAILED.
    Checking for active connection.
    Trying to get gateway address...
    ...from 'route'
    No default gateway.
    I hope you can help me!
    Yours,
    d347h

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    did you pay your internet bill? haha sorry man wish i could help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •