Results 1 to 3 of 3

Thread: Several config files reset on reboot

  1. #1
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    15

    Default Several config files reset on reboot

    Hello, I am having quite a bit of trouble with xorg.conf and /etc/network/interfaces reseting to default on every system reboot. So every time I start the system I have to write down ' aticonfig --initial' to startup (otherwise I get no screens found and gotta use fixvesa which makes the resolution awful). I read on google quite a bit of threads, but 99% of them seem to be connected with a buggy nvidia driver/script that resets xorg.conf, however I have nothing of such installled as I am with a Ati GPU. Another thing I tried is chattr +i /etc/X11/xorg.conf, but I get the following error:

    chattr: Inappropriate ioctl for device while reading flags on /etc/X11/xorg.conf
    (same happens with /etc/network/interfaces)

    I'm running Backtrack 4 R2 from a Persistent USB on a MSI GX740 laptop with an Ati HD5870. I used the HOW-TO guide – Install BackTrack Persistent to USB (With Nessus). Everything else works so far.

    Any help would be appreciated.

    Thanks in advance.

  2. #2
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    15

    Default Re: Several config files reset on reboot

    It seems fstab and and clock settings also reset However, /etc/group for example doesn't reset as I have edited the audio string to add 'root' to get sound and it stays between reboots

  3. #3
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    15

    Default Re: Several config files reset on reboot

    Since no one seems to know what could be the problem I decided to completely wipe out the usb stick and reinstall everything all over again step by step by the Install BackTrack Persistent to USB (With Nessus) from the How To section. Everything went well, I installed the ati's latest official drivers, did a aticonfig --initial and rebooted. However once again, xorg.conf has reset to default and I got a vesa: no screens found error :/ aticonfig --initial fixes the problem, but same thing happens on every reboot.

    Known config files to reset so far:
    /etc/X11/xorg.conf
    /etc/network/interfaces
    /etc/fstab

    and also passwd command resets after reboot, no idea where that is even stored. (after rebooting passwd resets to toor).

    All in all it seems it has something to do with the /etc/ folder or god knows what, and so far no sight of fixing this. Does anyone at least have any suggestions on how to set those particular files to not change (temporary manual fix so to speak) ?

    Thanks in advance

Similar Threads

  1. How to reset Backtrack
    By atnowhere in forum Beginners Forum
    Replies: 1
    Last Post: 09-02-2010, 09:21 PM
  2. how to save config after reboot backtrack 4
    By vikjava in forum OLD Newbie Area
    Replies: 18
    Last Post: 10-05-2009, 03:38 AM
  3. Realtek works before reboot, after reboot nothing works. Cant even reinstall card.
    By rowebil in forum OLD BackTrack 4 Software Related Issues
    Replies: 0
    Last Post: 08-14-2009, 03:50 AM
  4. Reset mac on BT3
    By magianegra in forum OLD Newbie Area
    Replies: 10
    Last Post: 12-28-2008, 11:23 AM
  5. Bt2final HD install, no "reset" after reboot
    By _loco in forum OLD BackTrack v2.0 Final
    Replies: 8
    Last Post: 11-03-2007, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •