Results 1 to 4 of 4

Thread: Issue with Python 2.6 and W3af

  1. #1
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    1

    Default Issue with Python 2.6 and W3af

    Hi there,

    I have this when I try to run ./w3af

    Code:
    root@bt:/pentest/web/w3af# apt-get install  python-gtk2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python-gtk2 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@bt:/pentest/web/w3af# ./w3af_gui
    You have to install GTK and PyGTK versions >=2.12 to be able to run the GTK user interface.
        - On Debian based distributions: apt-get install python-gtk2
        - On Mac: sudo port install py25-gtk
    root@bt:/pentest/web/w3af#
    What s wrong ? It is asking for something already installed.

    Thank you

  2. #2
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    1

    Default Re: Issue with Python 2.6 and W3af

    Hi there,

    I have similar problems as well trying to run w3af.

    Code:
    carl@bt:~/w3af# ./w3af_gui
    Error: Python 2.5 was found and Python = 2.6 is required.
    carl@bt:~/w3af#
    Was going through the w3af user guide and it seems the python requirements to run the tool is only python 2.5 instead of 2.6.

    Is there any guru out there that could help with this problem?

    I tried to install python 2.6 but I'm just worried it will make matters worse. Hence, I'm not able to use w3af for now.

    Thanks and regards,

  3. #3
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    1

    Default Re: Issue with Python 2.6 and W3af

    Hi,

    I´m also having problems with the last version of w3af.

    root@xxx:/pentest/web/w3af# ./w3af_console
    Your python installation needs the following packages:
    SOAPpy pyOpenSSL libxml2 pysvn scapy

    On debian based systems:
    sudo apt-get install python-soappy python-pyopenssl python-lxml python-svn python-scapy

    On a mac with mac ports installed:
    sudo port install py26-socket-ssl py26-openssl

    root@xxx:/pentest/web/w3af# apt-get install python-soappy python-pyopenssl python-lxml python-svn python-scapy
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    python-soappy is already the newest version.
    python-pyopenssl is already the newest version.
    python-lxml is already the newest version.
    python-svn is already the newest version.
    python-scapy is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    Does anyone have this kind of issue?

    Best Regards

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Issue with Python 2.6 and W3af

    I think you guys will have to wait for Backtrack 5 to come out to be able to use the latest w3af, it requires a newer version of python.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. w3af GUI
    By playtrack in forum BackTrack Bugs
    Replies: 2
    Last Post: 02-18-2010, 09:04 AM
  2. bug in w3af
    By p3nt3st in forum OLD BT4beta Bugs and Fixes
    Replies: 3
    Last Post: 04-08-2009, 04:03 AM
  3. w3af -g ( GTK ? / BT3 ? )
    By opreat0r in forum OLD Programming
    Replies: 21
    Last Post: 10-14-2008, 01:47 AM
  4. w3af probs
    By digiuk in forum OLD BT3beta General
    Replies: 2
    Last Post: 03-26-2008, 09:02 PM
  5. it will be great to have w3af in BT
    By eldraco in forum OLD Feature requests
    Replies: 1
    Last Post: 11-22-2007, 05:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •