Results 1 to 4 of 4

Thread: Can't install ndiswrapper

  1. #1
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    2

    Question Can't install ndiswrapper

    Hi, this is my first post on this forum and I'm completely new to linux, so I got stuck in first steps.

    I've tried to install ndiswrapper (without internet connection) but I've got a few errors, and I've googled them but nothing helped:

    Code:
    root@bt:/usr/var/ndiswrapper-1.56# sudo make install
    make -C driver install
    make[1]: Entering directory `/usr/var/ndiswrapper-1.56/driver'
    make -C /usr/src/linux-source-2.6.35.8 M=/usr/var/ndiswrapper-1.56/driver
    make[2]: Entering directory `/usr/src/linux-source-2.6.35.8'
    
      WARNING: Symbol version dump /usr/src/linux-source-2.6.35.8/Module.symvers
               is missing; modules will have no dependencies and modversions.
    
      LD      /usr/var/ndiswrapper-1.56/driver/built-in.o
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/crt_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/hal_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/ndis_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/ntoskernel_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/ntoskernel_io_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/rtl_exports.h
      MKEXPORT /usr/var/ndiswrapper-1.56/driver/usb_exports.h
      CC [M]  /usr/var/ndiswrapper-1.56/driver/crt.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/hal.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/iw_ndis.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/loader.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/ndis.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/ntoskernel.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/ntoskernel_io.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/pe_linker.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/pnp.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/proc.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/rtl.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/wrapmem.o
      CC [M]  /usr/var/ndiswrapper-1.56/driver/wrapndis.o
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c: In function 'set_multicast_list':
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:953: error: 'struct net_device' has no member named 'mc_count'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:956: error: 'struct net_device' has no member named 'mc_count'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:960: error: 'struct net_device' has no member named 'mc_count'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:960: warning: type defaults to 'int' in declaration of '_min2'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:960: error: 'struct net_device' has no member named 'mc_count'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:967: error: 'struct net_device' has no member named 'mc_list'
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:968: error: dereferencing pointer to incomplete type
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:969: error: dereferencing pointer to incomplete type
    /usr/var/ndiswrapper-1.56/driver/wrapndis.c:971: error: dereferencing pointer to incomplete type
    make[3]: *** [/usr/var/ndiswrapper-1.56/driver/wrapndis.o] Error 1
    make[2]: *** [_module_/usr/var/ndiswrapper-1.56/driver] Error 2
    make[2]: Leaving directory `/usr/src/linux-source-2.6.35.8'
    make[1]: *** [modules] Error 2
    make[1]: Leaving directory `/usr/var/ndiswrapper-1.56/driver'
    make: *** [install] Error 2
    And I have one more question, is it true that when I use ndiswrapper for my wirelles usb I wouldn't be able to crack WEP and other encriptions ?

  2. #2
    Senior Member iproute's Avatar
    Join Date
    Jan 2010
    Location
    Midwest, USA
    Posts
    192

    Default Re: Can't install ndiswrapper

    As I recall ndiswrapper is in the repository, so you should be able to just use apt-get install ndiswrapper. I think there is even a gui for it(apt-get install ndiswrapper-gtk)? Anyway, also as memory serves, you would not be able to inject since ndiswrapper is really using the windows driver for the device to function.

  3. #3
    Just burned his ISO
    Join Date
    Apr 2011
    Posts
    2

    Default Re: Can't install ndiswrapper

    As I already said I'm totally new to this, but I believe (correct me if I'm wrong) that I must have internet connection in order to use apt-get install command.
    Anyways, when I use it I get error:

    Code:
    apt-get install ndiswrapper
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package ndiswrapper
    And I would appreciate if you could suggest me to buy good wireless usb which will work in Linux without ndiswrapper (or is there some other solution?)

  4. #4
    Senior Member iproute's Avatar
    Join Date
    Jan 2010
    Location
    Midwest, USA
    Posts
    192

    Default Re: Can't install ndiswrapper

    depends on where in the world you live regarding good usb wireless adapter. Stick with wireless G rather than N for best results and highest likeliehood for injection capability. Local retailers around me carry a particular belkin model that generally has the required chipset I've found. Again, key point being wireless G. If you need more range, think about directional anntenae of whatever type. But I digress....

Similar Threads

  1. Need Install Ndiswrapper
    By nuxbie22 in forum Beginners Forum
    Replies: 0
    Last Post: 04-08-2010, 12:23 PM
  2. help with ndiswrapper
    By zerond2exp in forum OLD BackTrack 3 Final
    Replies: 3
    Last Post: 08-24-2009, 02:18 PM
  3. ndiswrapper
    By Linux-iq in forum OLD Newbie Area
    Replies: 9
    Last Post: 09-26-2008, 02:43 AM
  4. Ndiswrapper?
    By colataroc in forum OLD Newbie Area
    Replies: 6
    Last Post: 06-10-2008, 02:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •