Results 1 to 4 of 4

Thread: Error for Wireless Request

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    4

    Default Error for Wireless Request

    I'm trying to connect BackTrack 4 RC2 to my wireless network with the following command:

    Code:
     iwconfig wlan0 essid my_network_name key My_WPA_Shared_Key
    however, I keep getting this error message:

    Error for wireless request "Set Encode" (8B2A): invalid argument "My_WPA_Shared_Key"
    I also tried the s: option like this:

    Code:
     iwconfig wlan0 essid my_network_name key s:My_WPA_Shared_Key
    but I got this error message:

    Error for wireless request "Set Encode" (8V2A) : SET failed on device wlan0 ; Invalid argument
    The "key" I used was my passphrase which we use to access the internet (its not a hex key). The router is a Linksys WRT54G2 and its "Security Mode" is WPA Personal.

    Any assistance will be greatly appreciated. Thanks in advance

  2. #2
    Good friend of the forums comaX's Avatar
    Join Date
    Feb 2010
    Location
    Paris, France
    Posts
    338

    Default Re: Error for Wireless Request

    Why won't you use Wicd ?
    wicd start
    wicd-curses / wicd-gtk

    If you absolutely want to do it that way, sorry, can't help you... I believe others do
    Running both KDE and GNOME BT5 flawlessly. Thank you !

  3. #3
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    4

    Default Re: Error for Wireless Request

    Quote Originally Posted by comaX View Post
    Why won't you use Wicd ?
    wicd start
    wicd-curses / wicd-gtk

    If you absolutely want to do it that way, sorry, can't help you... I believe others do

    Thanks very much comaX. It worked!

    I ran
    Code:
    wicd start
    wicd-curses
    the pressed the right arrow for Config, and in the Configuring preferences, I ignored the first two options (Use Static IPs, Use Static DNS). I choose the third option (Use DHCP Hostname), changed the DHCP Hostname (which was "bt") and selected "Automatically connect to this network". I enter the router's passphrase (Preshared Key) and F10 to save!

    However, in the Router's DHCP Client's Table, my Client Host Name appears as "bt" even though I changed it. Why?




    Quote Originally Posted by Jimmy87 View Post
    You're trying to connect to the network as if the security were set to WEP.

    Take a look at wpa_supplicant

    http://www.backtrack-linux.org/forum...tml#post188838
    Thanks very much for informing me what I was actually doing.

  4. #4
    Senior Member
    Join Date
    Jul 2010
    Location
    UK
    Posts
    136

    Default Re: Error for Wireless Request

    You're trying to connect to the network as if the security were set to WEP.

    Take a look at wpa_supplicant

    http://www.backtrack-linux.org/forum...tml#post188838
    Last edited by Jimmy87; 03-23-2011 at 12:26 PM.

Similar Threads

  1. WPA2: Error for wireless request "Set Encode" (8B2A)
    By kiowa50161 in forum Beginners Forum
    Replies: 1
    Last Post: 01-17-2011, 07:46 PM
  2. Replies: 1
    Last Post: 07-23-2010, 08:13 AM
  3. metasploit -msfupdate error - svn : PROFIND request error
    By aisketui in forum OLD BT3beta Software related issues
    Replies: 2
    Last Post: 02-11-2009, 03:23 AM
  4. Error for wireless request "Set Mode" (8B06)
    By andyem in forum OLD Newbie Area
    Replies: 14
    Last Post: 09-02-2007, 03:48 PM
  5. error for wireless request "set mode"
    By haiishq in forum OLD Newbie Area
    Replies: 4
    Last Post: 07-13-2007, 03:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •