Results 1 to 3 of 3

Thread: VitualBox on BT4 R2

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Posts
    56

    Default VitualBox on BT4 R2

    Hi,
    I've been trying to install VirtualBox on R2, but getting the following error

    Code:
    dpkg -i virtualbox-4.0_4.0.4-70112~Ubuntu~maverick_i386.deb
    Selecting previously deselected package virtualbox-4.0.
    (Reading database ... 257490 files and directories currently installed.)
    Unpacking virtualbox-4.0 (from virtualbox-4.0_4.0.4-70112~Ubuntu~maverick_i386.deb) ...
    dpkg: dependency problems prevent configuration of virtualbox-4.0:
     virtualbox-4.0 depends on libpython2.6 (>= 2.6); however:
      Package libpython2.6 is not installed.
     virtualbox-4.0 depends on libqt4-network (>= 4:4.5.3); however:
      Version of libqt4-network on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqt4-opengl (>= 4:4.5.3); however:
      Version of libqt4-opengl on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqtcore4 (>= 4:4.7.0~beta1); however:
      Version of libqtcore4 on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqtgui4 (>= 4:4.7.0~beta1); however:
      Version of libqtgui4 on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian is not installed.
     virtualbox-4.0 depends on libssl0.9.8 (>= 0.9.8m-1); however:
      Version of libssl0.9.8 on system is 0.9.8g-10.1ubuntu2.6.
     virtualbox-4.0 depends on libstdc++6 (>= 4.4.0); however:
      Version of libstdc++6 on system is 4.3.2-1ubuntu12.
     virtualbox-4.0 depends on libxml2 (>= 2.7.4); however:
      Version of libxml2 on system is 2.6.32.dfsg-4ubuntu1.1.
    dpkg: error processing virtualbox-4.0 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     virtualbox-4.0
    I then followed the steps written in Wiki, but that didnn't help either.
    Then to install headers, I tried running
    Code:
     dpkg --force-depends -i virtualbox-4.0_4.0.4-70112~Ubuntu~maverick_i386.deb
    The output of his command was

    Code:
    (Reading database ... 258084 files and directories currently installed.)
    Preparing to replace virtualbox-4.0 4.0.4-70112~Ubuntu~maverick (using virtualbox-4.0_4.0.4-70112~Ubuntu~maverick_i386.deb) ...
    Unpacking replacement virtualbox-4.0 ...
    dpkg: virtualbox-4.0: dependency problems, but configuring anyway as you request:
     virtualbox-4.0 depends on libpython2.6 (>= 2.6); however:
      Package libpython2.6 is not installed.
     virtualbox-4.0 depends on libqt4-network (>= 4:4.5.3); however:
      Version of libqt4-network on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqt4-opengl (>= 4:4.5.3); however:
      Version of libqt4-opengl on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqtcore4 (>= 4:4.7.0~beta1); however:
      Version of libqtcore4 on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libqtgui4 (>= 4:4.7.0~beta1); however:
      Version of libqtgui4 on system is 4.4.3-0ubuntu1.4.
     virtualbox-4.0 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian is not installed.
     virtualbox-4.0 depends on libssl0.9.8 (>= 0.9.8m-1); however:
      Version of libssl0.9.8 on system is 0.9.8g-10.1ubuntu2.6.
     virtualbox-4.0 depends on libstdc++6 (>= 4.4.0); however:
      Version of libstdc++6 on system is 4.3.2-1ubuntu12.
     virtualbox-4.0 depends on libxml2 (>= 2.7.4); however:
      Version of libxml2 on system is 2.6.32.dfsg-4ubuntu1.1.
    Setting up virtualbox-4.0 (4.0.4-70112~Ubuntu~maverick) ...
    Adding group `vboxusers' (GID 132) ...
    Done.
    Stopping VirtualBox kernel modules:.
    Uninstalling old VirtualBox DKMS kernel modules:.
    Trying to register the VirtualBox kernel modules using DKMS:
    * Failed, trying without DKMS
    Recompiling VirtualBox kernel modules:.
    Starting VirtualBox kernel modules:.
    Then, when I tried running it, I got

    Code:
    Warning: program compiled against libxml 207 using older 206
    VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory


    After that, I ran
    Code:
    uname -a
    and an this command
    Code:
    apt-get install linux-headers-2.6.35.8
    where 2.6.35.8 is the output of uname.
    It's output was
    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libsdl1.2debian libsdl1.2debian-alsa libts-0.0-0 libdirectfb-1.0-0
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
      linux-headers-2.6.35.8
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 6237kB of archives.
    After this operation, 46.5MB of additional disk space will be used.
    Get:1 http://archive.offensive-security.com pwnsauce/macroverse linux-headers-2.6.35.8 2.6.35.8-10.00.Custom [6237kB]
    Fetched 6237kB in 8min10s (12.7kB/s)
    Selecting previously deselected package linux-headers-2.6.35.8.
    (Reading database ... 257588 files and directories currently installed.)
    Unpacking linux-headers-2.6.35.8 (from .../linux-headers-2.6.35.8_2.6.35.8-10.00.Custom_i386.deb) ...
    Setting up linux-headers-2.6.35.8 (2.6.35.8-10.00.Custom) ...
    Then I execute, ap-get update, install -f and upgrade commands. Then tried installing trhough apt-get as well as through downloaded .deb package. But still getting same errors.
    Can anybody help ?
    [FONT="System"][COLOR="DarkSlateBlue"][B]I am not arrogant, just better than you.[/B][/COLOR][/FONT]

  2. #2
    Member
    Join Date
    Feb 2009
    Location
    0,0
    Posts
    90

    Default Re: VitualBox on BT4 R2

    don't worry about me I am msfconsole retarded

  3. #3
    Senior Member iproute's Avatar
    Join Date
    Jan 2010
    Location
    Midwest, USA
    Posts
    192

    Default Re: VitualBox on BT4 R2

    Here is a bash script I've made to simplify it for you. Bear in mind a newer version than 3.1 is likely available in the repo by now. you can find out with
    Code:
    apt-cache search virtualbox
    after you've added the oracle repositories, and ran apt-get update.

    anyway here is the script. Copy it into kate or something, save it and make it executable.
    Code:
    #! /bin/bash
    echo "deb http://download.virtualbox.org/virtualbox/debian intrepid non-free" >> /etc/apt/sources.list
    wget -q http://download.virtualbox.org/virtualbox/debian/sun_vbox.asc -O- | sudo apt-key add -
    apt-get update
    #apt-cache search virtualbox (use this command to find if newer versions than 3.1 are available.  It is shown here to demonstrate that this command should be done after oracle repo is added and updated)
    apt-get install virtualbox-3.1
    Also I prefer to use sun_vbox.asc rather than oracle_vbox.asc that is shown in the BT wiki as it avoids the GPG errors.
    Last edited by iproute; 03-22-2011 at 05:43 AM.

Similar Threads

  1. BT4 lieber in der VitualBox oder in VMWare laufen lassen?
    By Darvin81 in forum Anfänger Ecke
    Replies: 11
    Last Post: 01-29-2010, 12:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •