Morning!

I've run into a snag when running the peach fuzzer. The python script runs fine when you don't evoke any command line options, but crashes when you attempt to test any of the pits.

For example, when I attempt to test any of the samples that come with peach, it cannot find the module 'psyco'. I've searched my whole BT4 R2 install, and it doesn't exist.

Here's the output:

Code:
root@bt:/pentest/fuzzers/peach# ./peach.py -t samples/HTTP.xml

] Peach 2.2.1 Runtime
] Copyright (c) Michael Eddington

Traceback (most recent call last):
  File "./peach.py", line 251, in <module>
    from Peach.Engine import *
  File "/pentest/fuzzers/peach/Peach/__init__.py", line 41, in <module>
    import Generators, Publishers, Transformers
  File "/pentest/fuzzers/peach/Peach/Publishers/__init__.py", line 37, in <module>
    import file, sql, stdout, tcp, udp, com, process, http, icmp, raw, remote
  File "/pentest/fuzzers/peach/Peach/Publishers/remote.py", line 36, in <module>
    from Peach.Engine.engine import Engine
  File "/pentest/fuzzers/peach/Peach/Engine/engine.py", line 755, in <module>
    from Peach.Engine.parser import *
  File "/pentest/fuzzers/peach/Peach/Engine/parser.py", line 53, in <module>
    from Peach.Engine.dom import *
  File "/pentest/fuzzers/peach/Peach/Engine/dom.py", line 3511, in <module>
    import psyco
ImportError: No module named psyco
I am running a pretty vanilla HDD install of BT2 R2 and I did attempt to update the system via apt-get update ; apt-get upgrade

I did see another user having this issue in what looked to be an older version of BT4 but the thread seems to just die.

Anyone else seeing this behavior?

Mods: My apologies if this is in the wrong forum. Wasn't sure where to put it.