Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: macchanger on startup.

  1. #11
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    SO SORRY the correct path is home/.kde/Autostart
    don't forget the dot before kde
    you copy your script xxxx.sh to this dir
    you must also give execution rights
    just right click the file >> permissions >> is executable must be checked >> apply >> then reboot >> normally it's roxx

    SORRY AGAIN, smoke too much MJ....
    see u

  2. #12
    Member Eristic's Avatar
    Join Date
    Aug 2006
    Posts
    188

    Default

    Quote Originally Posted by shamanvirtuel View Post
    SORRY AGAIN, smoke too much MJ....
    see u
    .........

    lol

  3. #13
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Quote Originally Posted by shamanvirtuel View Post
    SO SORRY the correct path is home/.kde/Autostart
    don't forget the dot before kde
    you copy your script xxxx.sh to this dir
    you must also give execution rights
    just right click the file >> permissions >> is executable must be checked >> apply >> then reboot >> normally it's roxx

    SORRY AGAIN, smoke too much MJ....
    see u
    WOW! No need for you to apologize shamanvirtuel...I'm the one needing help!

    Ok..i went back into the .kde autostart and clicked on my MACCHANGER.sh and the MACCHANGER.sh~ and made them BOTH executable...and TA DA!! It worded like magic!! THANK YOU! but the dot I was referring to was not the dot as in .kde it was the dot that appears in the txt file itself when I first open the txt document to start editing it. I just thought it was odd for a dot to be there and well..im rambling now..but you see what I mean. And is there a script where I can make this the default macchander address 00:11:22:33:44:55 ?? Id rather have that than the random one. But thanks again for your help...you and Eristic as well. BTW Eristic did you ever get a chance to test out your SRC's range over the weekend?? Just currious.

  4. #14
    Member Eristic's Avatar
    Join Date
    Aug 2006
    Posts
    188

    Default

    Quote Originally Posted by Xploitz View Post
    WOW! No need for you to apologize shamanvirtuel...I'm the one needing help!

    Ok..i went back into the .kde autostart and clicked on my MACCHANGER.sh and the MACCHANGER.sh~ and made them BOTH executable...and TA DA!! It worded like magic!! THANK YOU! but the dot I was referring to was not the dot as in .kde it was the dot that appears in the txt file itself when I first open the txt document to start editing it. I just thought it was odd for a dot to be there and well..im rambling now..but you see what I mean. And is there a script where I can make this the default macchander address 00:11:22:33:44:55 ?? Id rather have that than the random one. But thanks again for your help...you and Eristic as well. BTW Eristic did you ever get a chance to test out your SRC's range over the weekend?? Just currious.
    Instead of --random, just substitute your value with --mac=00:11:22:33:44:55. I think that would work.

    Also, I have noticed that too. I think it is like in MS Word where you enable the feature where it puts (dots) for spaces and lil "p" for paragraph markers. I don't see the point of it, but it doesn't affect the file. I was confused about it, but noticed it made no difference so just ignored it instead of finding out what it was.

  5. #15
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Quote Originally Posted by Eristic View Post
    Instead of --random, just substitute your value with --mac=00:11:22:33:44:55. I think that would work.

    Also, I have noticed that too. I think it is like in MS Word where you enable the feature where it puts (dots) for spaces and lil "p" for paragraph markers. I don't see the point of it, but it doesn't affect the file. I was confused about it, but noticed it made no difference so just ignored it instead of finding out what it was.
    Yea..the dot thing was throwing me a little..I figured it was nothing...but I wanted to make sure. I'm a n00B to Linux but I'm learning it at a good pace. Ok..I'll try this line in my .sh text and see if it works and post my findings after I pick up my little girl from school..which I gotta do right now..but thanks again for you guy's patience with me.

  6. #16
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    -mac=00:11:22:33:44:55 NO look this log

    macchanger -mac 00:11:22:33:44:55 eth1
    set device name: No such device
    macchanger --mac 00:11:22:33:44:55 eth1
    Current MAC: 11:11:33:33:45:55 (unknown)
    Faked MAC: 00:11:22:33:44:55 (Cimsys Inc)


    " --mac 00:11:22:33:44:55" wiil work not with only - you need --
    " -m 00:11:22:33:44:55 will work too
    but
    -mac 00:11:22:33:44:55 WONT WORK
    be sure too have make ifconfig wlan0 down ,macchangeand finally ifconfig wlan0 inthis order

    your start-up script macchanger.sh in home/.kde/Autostart/ should look like this :

    ifconfig wlan0 down
    macchanger --mac 00:11:22:33:44:55 wlan0
    ifconfig wlan0 up

    don't forget to make it executable

  7. #17
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Thumbs up

    Quote Originally Posted by shamanvirtuel View Post
    -mac=00:11:22:33:44:55 NO look this log

    your start-up script macchanger.sh in home/.kde/Autostart/ should look like this :

    ifconfig wlan0 down
    macchanger --mac 00:11:22:33:44:55 wlan0
    ifconfig wlan0 up

    don't forget to make it executable
    Ok..ok..Im getting this now. Its all starting to come together. So technically this autorun folder will run everything in it at startup..everytime. Ok..Ok...and I could even go as far as to do this??? --------->>>>

    ifconfig wlan0 down
    macchanger --mac 00:11:22:33:44:55 wlan0
    ifconfig wlan0 up
    airmon-ng start wlan0 6
    airodump-ng -c 6 --bssid [AP mac here] -w [File name] --ivs wlan0 ...........for my network
    aireplay-ng -1 0 -e [essid] -a [AP mac here] -h 00:11:22:33:44:55 wlan0
    aireplay-ng -3 -b [AP mac here] -h 00:11:22:33:44:55

    of course everything in a bracket I would tailor to my networks details. Would this be good?? Just currious..and then manually do the aircrack-ng *.ivs -b [AP mac here]


    well anyways your script worked shamanvirtuel. Thank you once again for your time and patience. Im still learning Linux and I wish Backtrack2 had a book out like windows XP does..like a tips and tricks thing. Yea..that would be super sweet!! Cause the Backtrack website doesn't go into a lot of n00bie stuff. :-(
    Thanks again guys!! Happy hunting!!

  8. #18
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    toolong for me lol
    the best thing is that you can add

    airoscript.sh

    to the end of your script

    after select interface when asked you will take to a menu
    type 9 >> enable monitor mode
    type 11 >> scan for target, select target and automated attacks linked ...

    have other things very usefull .... thhis script is a must test one time , must love it script............
    according to me

    hope helps
    see u

  9. #19
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Ok..thanks..ive never played with airoscript before...I think im taking on 2 much at a time for now...Im getting a headache!! But in time I will try it...thanks again shamanvirtuel, my friend.

  10. #20
    Junior Member
    Join Date
    Jan 2010
    Posts
    79

    Default

    Just throwing in my two cents in here, I know I'm late in the game, but you shouldn't be using the kde Autostart directory for any network configuration. It's purpose is to autostart KDE applications. Network configurations, such as this specific one belong in /etc/rc.d/rc.inet1 . Put the macchanger command, preferably with full path, at the beginning of script. The command should run before receiving an IP address, and before network services (/etc/rc.d/rc.inet2) start. Putting it in Autostart, doesn't allow for you to boot in to any other init state, and get the same results.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •