hello everyone,

In case anyone else was trying to get this to work...

I installed BT4 R2 on an old Asus EEE 1000HE with the rt2860 wireless card installed. I realised that the default drivers did not support injection. To fix this I installed the compat-wireless drivers shown in the wiki. But I did not use any of the patches shown. Here is the code:

Code:
cd /usr/src/
wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-11-07.tar.bz2
tar jxpf compat-wireless-*
cd compat-wireless-*
Being the newbie that I am I installed all the drivers:

Code:
make
make install
make wlunload
And then I rebooted...

The wireless should now be working with injection!


note:

B]1)[/B] Before installing compat-wireless the driver being used was rt2860, however after installation it became rt2800pci
[

2)in the above code I chose to install all the drivers which was very time consuming. If you refer to the wiki you will see there is an option for specifying a specific driver. Since I did not know what driver would work I installed them all and hoped for the best! (lol i'm such a newb )

3) before the aireplay-ng -9 test make sure you run airmon-ng start wlan0 <Channel> with the correct channel that your AP is on. Otherwise it will fail the test!

I'm sure there are many ways to do this whole thing better but this is the method I got my 1000He to work correctly. I must say the driver support on the BT4 R2 is much much better than the previous versions, Most of the cards work well out of the box.