Guys,

In the latest versions of w3af we've added a new dependency, "python-svn". We've tested this in Ubuntu 8 and 10 and it works, but in BT we get the following:

Code:
>>> import pysvn
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/pysvn/__init__.py", line 116, in <module>
    raise ImportError, 'pysvn was built against newer (svn, apr, etc.) libraries then the ones installed on this system. %s' % str(e)
ImportError: pysvn was built against newer (svn, apr, etc.) libraries then the ones installed on this system. /usr/lib/libsvn_subr-1.so.1: undefined symbol: apr_memcache_add_server
This message appears after running "sudo apt-get install python-svn" and trying to use the recently installed library. My understanding is that the "libsvn1" package that's bundled with BT is incompatible with python-svn.

I'm trying to find an easy solution for w3af users to use while we identify the definitive solution; but I don't really have much time. I'll let you know what I can find.

Regards,

Andrés Riancho
w3af Project leader