Results 1 to 5 of 5

Thread: I/O error - encrypted USB install

  1. #1
    Just burned his ISO
    Join Date
    Jul 2006
    Posts
    17

    Default I/O error - encrypted USB install

    Hi,

    I have an encrypted thumbdrive install of BTR2 set up using the howto guide. It's been working fine but I tried to update framework3 and kept getting an I/O error for one of the .svn directories in /opt.

    I tried to remove framework3 both by manually deleting the files and using apt-get. Both failed with the same I/O error.

    Guessing this is due to bad blocks or a filesystem problem?

    How do I fix this? My first action would be to mount the root fs using another Linux box and run an fsck - the problem is I don't know how to mount the encrypted fs on my Ubuntu machine (and don't know what to google for - sorry). Also not sure whether this would deal with bad sectors?

    Any guidance appreciated.

    Thanks.

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: I/O error - encrypted USB install

    You should probably include the exact text of the errors you are getting.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  3. #3
    Just burned his ISO
    Join Date
    Jul 2006
    Posts
    17

    Default Re: I/O error - encrypted USB install

    Not sure that it will help much but:

    Code:
    root@bt:~# apt-get remove framework3 --ignore-missing
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED:
      framework3
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    (Reading database ... 256653 files and directories currently installed.)
    Removing framework3 ...
    dpkg: error processing framework3 (--remove):
     failed to delete `/opt/metasploit3/msf3/external/source/byakugan/detours/.svn/prop-base/disasm.cpp.svn-base.dpkg-tmp': Input/output error
    Errors were encountered while processing:
     framework3
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  4. #4
    Just burned his ISO
    Join Date
    Jul 2006
    Posts
    17

    Default Re: I/O error - encrypted USB install

    No hints peeps?

  5. #5
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Re: I/O error - encrypted USB install

    Can you manually delete the file which is causing the error?
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

Similar Threads

  1. BT4 Encrypted HDD install using LUKS and LVM
    By imported__arc_ in forum OLD BT4beta HowTo's
    Replies: 15
    Last Post: 01-30-2010, 12:40 PM
  2. BT4 Encrypted HDD install using LUKS and LVM booting from usb stick
    By imported__arc_ in forum OLD BT4beta HowTo's
    Replies: 1
    Last Post: 02-14-2009, 12:47 PM
  3. Encrypted Root Hard Drive Install - HOWTO
    By interspective in forum OLD BackTrack 3 Final
    Replies: 5
    Last Post: 11-04-2008, 09:22 PM
  4. bt3 - eeePC - Install on encrypted root fs
    By karmaM in forum OLD BackTrack3 Howtos
    Replies: 0
    Last Post: 10-24-2008, 10:04 AM
  5. Creating an encrypted VMware 'real' install of Back | Track 3
    By imported_ecsployt in forum OLD Tutorials and Guides
    Replies: 12
    Last Post: 05-27-2008, 12:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •