Results 1 to 5 of 5

Thread: ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

  1. #1
    Junior Member nam5301's Avatar
    Join Date
    Nov 2010
    Posts
    72

    Exclamation ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

    http://forums.amd.com/game/messagevi...hreadid=127119

    I installed the ati radeon HD 5670 linux video driver inside the DRIVER'S CD at the command prompt of root, and it says no screen found. I even tried to install the driver from this link:
    http://www.ati-forum.de/general/down...erie/?68ff7617 and still doesn't work....
    The installation of the driver works fine, but after installation, backtrack says screen not found...

    A lot of people are saying Ati 5670 is not compatible with Linux? Is this true? Is there an update or something? Moderators help.....

    Last edited by nam5301; 01-29-2011 at 04:13 PM.

  2. #2
    Just burned his ISO
    Join Date
    Jan 2011
    Location
    Mississauga, Ontario, Canada
    Posts
    20

    Default Re: ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

    This not in any way a BT problem, it is a Linux problem. As you sent me a PM asking for help, I will respond via PM'ing.

    ( don't stress...any graphics card should work with linux...it's what makes it such a robust Op Sys )
    -=+ Support the Red & White Machine +=- -=+ Live To Ride-Ride To Live +=- -=+ Angels Don't Die - We Go To Hell And Regroup +=-

  3. #3
    Junior Member nam5301's Avatar
    Join Date
    Nov 2010
    Posts
    72

    Thumbs up Re: ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

    A member of this forum (AlphaandOmega) helped me on this problem. He told me to type fixvesa, then type startx, then I re-installed the video driver for my ATI 5670 . Thank you! So if any of you who have the ATI 5xxx Series video card that have this same problem, use this method to fix it.
    Last edited by nam5301; 01-29-2011 at 08:24 PM.

  4. #4
    Senior Member iproute's Avatar
    Join Date
    Jan 2010
    Location
    Midwest, USA
    Posts
    192

    Default Re: ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

    The ATI issue is definitely more just a linux problem. Xorg and ATI don't always like to play nicely.

  5. #5
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    3

    Default Re: ATI Radeon HD 5670 Video Card doesn't work in Backtrack?

    Hello, I've a similar problem but fix-vesa didn't fix it on my ATI HD 5430 (native screen resolution : 1600x900). I installed BackTrack 4 R2 on an USB Key, with a 4Go casper file (i checked MD5 and it's good). All my changes are saved (language, files added etc.) but there is 1 thing not saved : video config.
    When I start on usb, all is booting correctly and I see console. I type startx and get :

    "no screen found
    giving up.
    xinit: Connection refused (errno 111): unable to connect to X server
    xinit: No such process (errno 3): Server error."

    If I install ATI drivers after that, i can go on desktop with native screen resolution. At restart, no screen found... i tried to type fix-vesa, i can go to desktop without reinstall the drivers but i've bad resolution (1024x768) I tried dpkg-reconfigure xserver-xorg it didn't work. So i always have to install drivers at boot if i want to use BT correctly. Any1 have an idea ?

    P.S. : My xorg.conf :

    Section "Device"
    Identifier "Configured Video Device"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection

Similar Threads

  1. Replies: 1
    Last Post: 09-07-2010, 09:50 PM
  2. Backtrack 3, Keybot doesn't work
    By Nur4mon in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-23-2009, 01:43 PM
  3. konsole in BackTrack 3 (usb) doesn't work
    By kveita in forum OLD Newbie Area
    Replies: 2
    Last Post: 08-16-2009, 10:33 AM
  4. Backtrack 3 - Packet injection doesn't work
    By Dr.Gaga in forum OLD Newbie Area
    Replies: 5
    Last Post: 12-31-2008, 01:39 AM
  5. backtrack 3 doesn't work
    By imported__code_ in forum OLD Newbie Area
    Replies: 7
    Last Post: 10-01-2008, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •