Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: How To Enable Intel® PRO/Wireless 3945ABG Card In Backtrack

  1. #11
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    If you wana try this SHOULD allow injection
    Code:
    wget http://homepages.tu-darmstadt.de/~p_larbig/wlan/ipwraw-ng-2.0.0-10072007.tar.bz2
    tar -xjf ipwraw-ng*
    cd ipwraw-ng
    make
    sudo make install
    sudo make install_ucode
    echo "blacklist ipwraw" | sudo tee /etc/modprobe.d/ipwraw
    sudo depmod -ae
    To stop managed mode and start the card in monitor mode

    Code:
    airdriver-ng load 12
    or

    Code:
    sudo modprobe -r ipw3945
    sudo modprobe ipwraw
    To switch back to your old driver

    Code:
    sudo modprobe -r ipwraw
    sudo modprobe ipw3945
    to test injection

    Code:
    aireplay-ng --test wifi0
    If you are running a card that already has wifi0 your intel card will be wifi1

    You might have to update your kernel??? Have a go and if unsuccessful post back.

  2. #12
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Confirmed the drivers below allow injection on intels 3945 enjoy Would you guys like a full tutorial?

  3. #13
    Just burned his ISO
    Join Date
    Dec 2006
    Posts
    13

    Default

    Quote Originally Posted by joek1010 View Post
    You can also just do this:
    /sbin/ipw3945d

    That will also load the drivers for your card.

    For those interesting in packet injection, you may want to check this out: (forums.remote-exploit.org/showthread.php?t=6295&highlight=mac80211)
    Check out the third link that he posted (I can't post links yet, not enough posts).

    I haven't been able to get it to work yet, but it looks promising. I think the problem with packet injection is the intel drivers don't support it.
    The /sbin/ipw3945d will freeze my computer everytime and I need to reboot...

    I did attempt to use the drivers that enable packet injection for my 3945 however...I can only seem to keep it in monitor mode...it will NOT go back into managed... I am so confused..

    I just wish I kept up with linux when RedHat came out :-(

  4. #14
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Your problem is that you are probably not unloading the drivers. After injecting with ipraw you must unload them and then load the 3495 drivers and vice versa. If you guy check the first page or so of the tutorial section you should find a how too.

  5. #15
    Just burned his ISO
    Join Date
    Dec 2006
    Posts
    13

    Default

    well how can that be?

    the computer will freeze when I'm simply trying to load the ipw3945 drivers....I haven't even INSTALLED the raw drivers....I was just trying to get online is all!

  6. #16
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Ah I see I misunderstood. The solution to that is to upgrade your kernel. Some times the combination of driver ,laptop and kernel just don't mix. I am using the 2.6.22.9 kernel and my intel drivers work fine although I rarely use them.

  7. #17
    Just burned his ISO
    Join Date
    Dec 2006
    Posts
    13

    Default

    how do I go about that if I can't get online?

  8. #18
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Just use another pc and download the kernel and the two files needed for the intel drivers and then copy them on to your machine. Exitonly did a excellent write up on doing this in the tutorial section entitled "How to ipw395" or some thing like that. You should check it out.

  9. #19
    Just burned his ISO
    Join Date
    Dec 2006
    Posts
    13

    Default

    the ipw was disabled via the switch on the front of the laptop..that I guess only works when I boot into XP...so anyways...I got the drivers functioning...I updated to 0.9.1 on aircrack...but when I test injection....it will say

    Injection working! (test on my router which is a Netgear WGR614v8 in 128 bit WEP mode)

    and then it will send the packets....but I get 0% everytime....

    usually the second time around that I try the test...instead of it saying Injection
    working!....it will say no answer....and then send the packets...and still get 0

    I did somehow get like 3 of those packets sent to another AP...which I guess was automatically detected in my area...but only once..

    is there something that I am missing...the code I am using is

    aireplay -9 -b wifi0 I think lol...I did all this last night

    it reads well in airodump tho..

  10. #20
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default Stil problems with intel 3945 wireless card

    tried the 80211 -> misc load ipw 3945/4965 and all i get is

    ERROR: Module ipwraw does not exist in /proc/modules
    /bin/sh: ./unload: No such file or directory
    /bin/sh: ./load: No such file or directory


    Tried cd /usr/src/drivers/ipw3945-1.2.0

    but no drivers there only:

    ipwraw-ng/ iwlwifi-1.0.0/

    Tried loadin ipwraw but

    Loading 'ipwraw'...done.
    Waiting for /sys/class/net/wifi0/device/rtap_iface to appear....time out.
    Could not find wifi0 interface.


    any ideas? i am using the USB, extended version of backtrack 3

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •