Results 1 to 4 of 4

Thread: apt-get update && apt-get dist-upgrade

  1. #1
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    15

    Default apt-get update && apt-get dist-upgrade

    After reading Mr Muts tweet regarding some updates for w3af, chntpw and watobo

    I ran the apt-get update && apt-get dist-upgrade command. It got part way through and failed due to the below.

    Now im pretty new to linux in general, i know my way rnd and can do the basics but after a good few hours of trying to fix this myself along with my friend goodle. I cant crack it, could someone please help me out?

    ERROR is as of below


    Unpacking openvas-scanner (from .../openvas-scanner_3.1.1-bt0_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb (--unpack):
    trying to overwrite `/usr/local/lib/openvas/plugins/synscan.nes', which is also in package openvas-plugins
    Errors were encountered while processing:
    /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #2
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    15

    Default Re: apt-get update && apt-get dist-upgrade

    Anyone?

  3. #3
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: apt-get update && apt-get dist-upgrade

    Here: Upgrading - BackTrack Linux
    Also try removing openvas then upgrade or just pass the force option. If these methods fail I suggest a clean install.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  4. #4
    Just burned his ISO
    Join Date
    Jun 2009
    Posts
    15

    Default Re: apt-get update && apt-get dist-upgrade

    Quote Originally Posted by sickness View Post
    Here: Upgrading - BackTrack Linux
    Also try removing openvas then upgrade or just pass the force option. If these methods fail I suggest a clean install.
    Thanks for the response Sickness

    I got it sorted in the end, I’m guessing the libraries changed or something as i just uninstalled the packages in question then did an apt-get update && apt-get dist-upgrade again and it worked. I’m quite positive i tried that previously though

    Thanks none the less Sickness

Similar Threads

  1. OpenVAS broke after apt-get dist-upgrade?
    By lambon in forum BackTrack Bugs
    Replies: 6
    Last Post: 12-15-2010, 05:37 AM
  2. WUSB54GC not working after dist-upgrade
    By encrypt in forum BackTrack Bugs
    Replies: 2
    Last Post: 07-28-2010, 01:32 AM
  3. apt-get dist-upgrade issue
    By RageLtMan in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 13
    Last Post: 01-14-2010, 08:12 PM
  4. dist-upgrade and scapy broken
    By bofh28 in forum OLD BackTrack 4 Software Related Issues
    Replies: 4
    Last Post: 01-11-2010, 11:11 PM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •