Results 1 to 8 of 8

Thread: Ruby Gems Error after Metasploit Update

  1. #1
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    2

    Default Ruby Gems Error after Metasploit Update

    I have BT4 r2 loaded on a USB with persistence enabled. Persistence is working fine. Wanted to update metasploit did a:
    cd /pentest/exploits/framework3
    Directory changed properly, then did a:
    svn update
    loaded new updates brought version up to 11599
    then tried a ./msfconsole, got this error

    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `gem_original_require': no such file to load --
    msf/base/sessions/scriptable (LoadError)
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `require'
    from /opt/metasploit3/msf3/lib/msf/base/sessions/command_shell.rb:2
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `gem_original_require'
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `require'
    from /opt/metasploit3/msf3/lib/msf/base.rb:29
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `gem_original_require'
    from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:29:in
    `require'
    from /opt/metasploit3/msf3/lib/msf/ui/console/driver.rb:2
    from /opt/metasploit3/msf3/lib/msf/ui/console.rb:10:in `require'
    from /opt/metasploit3/msf3/lib/msf/ui/console.rb:10
    from /opt/metasploit3/msf3/lib/msf/ui.rb:10:in `require'
    from /opt/metasploit3/msf3/lib/msf/ui.rb:10
    from /usr/local/bin/msfconsole:111:in `require'
    from /usr/local/bin/msfconsole:111

    Did a:
    gem update --system

    Also did a:
    apt-get update
    And:
    apt-get upgrade

    Still no love.

    Ideas?

  2. #2
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    1

    Default Re: Ruby Gems Error after Metasploit Update

    I think that this is solely a 11599 error, as my console started crashing after I ran the update this evening. If you hear anything, keep us posted.

    -sP

  3. #3
    Member
    Join Date
    Feb 2009
    Location
    0,0
    Posts
    90

    Default Re: Ruby Gems Error after Metasploit Update

    Got room in that boat?

    It appears to me that the path /opt/metasploit3/msf3/lib/msf/base/sessions/scriptable does not exist and is called in the custom_require.rb on line 29. I'm not sure how it's populating the variable "path" in custom_require.rb. The comments say:

    # When RubyGems is required, Kernel#require is replaced with our own which
    # is capable of loading gems on demand.
    #
    # When you call <tt>require 'x'</tt>, this is what happens:
    # * If the file can be loaded from the existing Ruby loadpath, it
    # is.
    # * Otherwise, installed gems are searched for a file that matches.
    # If it's found in gem 'y', that gem is activated (added to the
    # loadpath).
    #
    # The normal <tt>require</tt> functionality of returning false if
    # that file has already been loaded is preserved.
    EDIT:

    command_shell.rb calls require 'msf/base/sessions/scriptable' which doesn't exist
    Last edited by cseven; 01-18-2011 at 08:38 PM.
    don't worry about me I am msfconsole retarded

  4. #4
    Junior Member
    Join Date
    Jun 2010
    Posts
    35

    Default Re: Ruby Gems Error after Metasploit Update

    I have the same problem, I shouldn't have done the update


    edit: so i reverted back to previous revision
    # svn up -r 11598
    Last edited by SecureSurfer; 01-18-2011 at 09:59 PM.

  5. #5
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    1

    Default 回复: Ruby Gems Error after Metasploit Update

    I also have the same problem!

  6. #6
    Senior Member
    Join Date
    Jun 2007
    Location
    UK
    Posts
    175

    Default Re: Ruby Gems Error after Metasploit Update

    Same problem
    # svn up -r 11598 worked for me
    thanks

  7. #7
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Ruby Gems Error after Metasploit Update

    Thanks for reporting this issue. It does appear to be something wrong. We will look into it and get it fixed.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  8. #8
    Just burned his ISO
    Join Date
    Jan 2011
    Posts
    2

    Default Re: Ruby Gems Error after Metasploit Update

    svn up -r 11598 worked for me also

Similar Threads

  1. Updating Ruby gems
    By hightech in forum Beginners Forum
    Replies: 1
    Last Post: 12-06-2010, 10:26 PM
  2. Goorecon cannot access ruby gems???
    By NewJack in forum Beginners Forum
    Replies: 4
    Last Post: 06-20-2010, 08:47 PM
  3. metasploit wont update:error
    By BigMac in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-01-2010, 09:06 AM
  4. how to update to ruby 1.9?
    By b3r00tb4ck in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-22-2009, 05:23 PM
  5. Svn Update Metasploit Error
    By fload in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-27-2009, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •