Hey guys,

The tip above didnt worked for me, but i found something that made the intel driver work.

Following this post: http://ubuntuforums.org/showthread.php?t=1400524

i'm just pasting here what that guy suggested:
Following the tip for creating the file "/etc/modprobe.d/i915-kms.conf" with the line "options i915 modeset=1" seems to have worked.
As i already said, i compiled the xorg in a diferent path (/opt/xorg) and instaled the intel driver 2.13.
After folowing this tip, it worked fine for me when i startx -- /opt/xorg/bin/Xorg.

Hope it helps.

Anyone know how to set the defaut path for startx? So i won't have to type the hole (startx -- /opt/xorg/bin/Xorg).

Sorry for any error.