Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Using WG511T with BT2 Live CD, how do I set my card to monitor mode?

  1. #1
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    7

    Default Using WG511T with BT2 Live CD, how do I set my card to monitor mode?

    I'm a noob to both linux and backtrack so bare with me guys. Mainly I'm going to start using BT for basic WEP cracking and wardriving. Using kismet/airodump/aircrack/aireplay etc.

    So I picked up my new WG511T today and I would appreciate a little help.

    How do I set the card to Monitor mode? I've got an intel card with the ipw2100 chipset and it works perfectly just using:
    Code:
    iwconfig eth1 mode monitor
    So I quickly figured out it's a bit trickier with the WG511T card.
    Using...:
    Code:
    iwconfig ath0 mode monitor
    ...will just get me:
    Code:
    Error for wireless request "Set Mode" (8B06) :
        SET failed on device ath0 ; Invalid argument.
    I've google'd it and I've read there's a way around this. I actually got it to work but it was pretty confusing to me so I was hoping anyone would care to explain how to do it properly.

  2. #2
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by XploD View Post
    I'm a noob to both linux and backtrack so bare with me guys. Mainly I'm going to start using BT for basic WEP cracking and wardriving. Using kismet/airodump/aircrack/aireplay etc.

    So I picked up my new WG511T today and I would appreciate a little help.

    How do I set the card to Monitor mode? I've got an intel card with the ipw2100 chipset and it works perfectly just using:
    Code:
    iwconfig eth1 mode monitor
    So I quickly figured out it's a bit trickier with the WG511T card.
    Using...:
    Code:
    iwconfig ath0 mode monitor
    ...will just get me:
    Code:
    Error for wireless request "Set Mode" (8B06) :
        SET failed on device ath0 ; Invalid argument.
    I've google'd it and I've read there's a way around this. I actually got it to work but it was pretty confusing to me so I was hoping anyone would care to explain how to do it properly.
    Have you tried setting it to monitor a specific channel?
    Code:
    iwconfig ath0 mode Monitor channel 6

  3. #3
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    7

    Default

    Quote Originally Posted by theprez98 View Post
    Have you tried setting it to monitor a specific channel?
    Code:
    iwconfig ath0 mode Monitor channel 6
    Still get the same error message.

  4. #4
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by XploD View Post
    Still get the same error message.
    ok, how about trying to lock the card into a specific mode first:

    Code:
    iwpriv ath0 mode 2
    locks card into 802.11b mode

  5. #5
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    7

    Default

    Quote Originally Posted by theprez98 View Post
    ok, how about trying to lock the card into a specific mode first:

    Code:
    iwpriv ath0 mode 2
    locks card into 802.11b mode
    Doesn't seem to work either.

  6. #6
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by XploD View Post
    Doesn't seem to work either.
    Are you sure your card is being enabled when you boot up/insert it?

  7. #7
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    7

    Default

    Quote Originally Posted by theprez98 View Post
    Are you sure your card is being enabled when you boot up/insert it?
    Yeah of course. I'm not that hardcore.

  8. #8
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by XploD View Post
    Yeah of course. I'm not that hardcore.
    Driver problem? I dunno...

    try the airmon-ng script

    airmon-ng start wifi0
    then try to set ath1 in monitor mode

  9. #9
    Just burned his ISO
    Join Date
    Apr 2007
    Posts
    7

    Default

    Quote Originally Posted by theprez98 View Post
    Driver problem? I dunno...

    try the airmon-ng script

    airmon-ng start wifi0
    then try to set ath1 in monitor mode
    Thank you! That worked.

    I really appreciate it man.

  10. #10
    Moderator theprez98's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    2,533

    Default

    Quote Originally Posted by XploD View Post
    Thank you! That worked.

    I really appreciate it man.
    No problem. Sorry for sending you on a wild goose chase. I was re-reading the original posts and didn't realize I hadn't even mentioned that yet.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •