Results 1 to 2 of 2

Thread: Updating Ruby gems

  1. #1
    Junior Member
    Join Date
    Oct 2008
    Posts
    27

    Question Updating Ruby gems?

    Hey guys,
    I updated metasploit via fasttrack. When I try to set the db_driver to mysql it says

    [*] Active Driver: sqlite3[*] Available: sqlite3[*] DB Support: Enable the mysql driver with the following command:[*] $ gem install mysql

    So, I tried "gem install mysql" via terminal and that gives me a problem

    ERROR: could not find gem mysql locally or in a repository

    my gem list ony shows

    *** LOCAL GEMS ***

    baffle (0.2.1)
    dot11 (0.1.0)
    exegesis (0.2.6)
    facets (2.5.2)
    httpclient (2.1.4, 2.1.3.1)
    ip (0.2.2)
    pNet-DNS (1.0.2)
    postgres-pr (0.5.0)
    rb-lorcon (0.1.0)
    rb-pcap (0.1.0)
    rest-client (1.0)
    wxruby (2.0.1)

    Next I try "gem update --system" and that gives me an erorr aswell

    ERROR: While executing gem ... (RuntimeError)
    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

    My question is how do I set metasploit to use mysql for a database ( trying to use armitage). Im running backtrack 4 final. Thanks
    Last edited by hightech; 12-05-2010 at 07:02 PM.
    Where is the any key ???

  2. #2
    Junior Member dec1bel's Avatar
    Join Date
    Dec 2010
    Location
    US
    Posts
    36

    Default Re: Updating Ruby gems

    I had this problem with an installation of Metasploit on an install of Ubuntu and haven't quite figured it out, but things should be set up properly to use MySQL in Metsploit on BT4R2.

    To update ruby gems try

    Code:
    gem help update

Similar Threads

  1. Goorecon cannot access ruby gems???
    By NewJack in forum Beginners Forum
    Replies: 4
    Last Post: 06-20-2010, 08:47 PM
  2. Python vs Ruby
    By kazalku in forum OLD Programming
    Replies: 5
    Last Post: 08-26-2009, 06:42 PM
  3. Learning ruby... My first ruby backdoor...
    By BigMac in forum OLD Programming
    Replies: 9
    Last Post: 06-03-2009, 11:32 PM
  4. Python or Ruby
    By 5ILENCE in forum OLD Newbie Area
    Replies: 0
    Last Post: 03-01-2009, 08:43 AM
  5. NEW Netbeans 6.0 + NEW Ruby IDE
    By shamanvirtuel in forum OLD Programming
    Replies: 4
    Last Post: 12-04-2007, 12:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •