Results 1 to 4 of 4

Thread: Workaround: Blank screen after boot Backtrack 4 R2.

Threaded View

  1. #1
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Workaround: Blank screen after boot Backtrack 4 R2.

    Some people are experiencing problems while booting Backtrack 4 R2, they either get a blank screen and freeze or an error message when booting in "Text Mode" similar to this one:

    Code:
    [<c05e3004>] ? acpi_os_release_object+0xd/0x11
    [<c06030f8>] ? acpi_ut_update_object_reference+0xb1/0x116
    [<c05fb4a9>] acpi_get_handle+0x6c/0x85
    [<c09fa444>] acpi_gts_bfs_check+0x16/0x5c
    [<c04519ba>] ? register_reboot_notifier+0x14/0x16
    [<c09fa5c9>] acpi_sleep_init+0x13f/0x14a
    [<c09fa810>] acpi_init+0x112/0x2c8
    [<c09fa6fe>] ? acpi_init+0x0/0x2c8
    [<c0401143>] do_one_initcall+0x51/0x13f
    [<c09d43f2>] kernel_init+0x197/0x218
    [<c09d425b>] ? kernel_init+0x0/0x218
    [<c04039be>] kernel_tread_helper+0x6/0x10
    So the main problem is the kernel can not find ACPI support.
    This is a kernel bug (80%) but I could be wrong, so if anyone can add more information or another workaround/fix please feel free to do so.

    Currently there are 2 workarounds for this issue:

    1. Revert back to the previous kernel 2.6.34: (RECOMMENDED SOLUTION)
    *You do this by installing a fresh R1, after that you upgrade all tools except the kernel.
    *This works just fine, all tools are working, and you should now have problems with injection either, if it was supported in R1.

    2. Boot with "noapic acpi=off" flags:
    *Now first before trying this you should take a look at what these two actually do:
    Advanced Configuration and Power Interface - Wikipedia, the free encyclopedia
    Advanced Programmable Interrupt Controller - Wikipedia, the free encyclopedia

    You can also use Google for more info.

    How to do this:

    *Plug in the LiveCD and when you enter grub, hit the "e" key:



    *After that select the "kernel" and hit "e" key again:



    *Type in the "noapic acpi=off" flags (without quotes ofc.) after that hit "Enter" and "b" to boot.



    Now Backtrack should boot.

    If you want to install it on a HDD or Persistent USB, remember to continue using the live cd, mount the /boot/grub/ partition and add "noapic acpi=off" to the menu.lst

    From here on it all depends if you're hardware is completely ACPI dependent or not.

    Turning ACPI off might:
    - Kill the CPU cores and leave only 1 enabled
    - Turn off cooling fans
    - No battery support (laptops)

    As I said this depends on your hardwares ACPI dependency.

    If you choose to run with "noapic acpi=off" I suggest, you check the cooling fans if they work and install lm-sensors for CPU temp support.

    Another known issue is the power off one, you won't be able to power off, however if you log out of X and type in:

    Code:
     shutdown -h 0
    You will see it is killing all running processes, stopping HDDs and then give you a message similar to:

    Code:
     System halted
    From this message you can just hit the power off button and it should turn off.


    If your hardware is not ACPI dependent you should be able to run without any problems but I suggest you check the CPU temp using lm-sensors from time to time just to make sure.

    IF YOU ARE NOT SURE ABOUT WHAT YOU ARE DOING I JUST WANT YOU TO KNOW THAT I AM NOT RESPONSIBLE FOR ANY HARDWARE DAMAGE THAT MIGHT OCCUR !!!!
    Last edited by sickness; 12-01-2010 at 11:40 AM.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. Blank screen
    By Upsman in forum OLD BT3final Support
    Replies: 2
    Last Post: 10-15-2008, 08:19 AM
  2. I've tried everything...Blank Screen...need help please
    By leadwings in forum OLD Newbie Area
    Replies: 5
    Last Post: 03-19-2008, 09:24 AM
  3. Blank screen on boot..
    By scottsee in forum OLD LiveCD Support
    Replies: 7
    Last Post: 11-07-2007, 10:25 PM
  4. Nothing happens (Blank screen)
    By sin_gage in forum OLD Newbie Area
    Replies: 7
    Last Post: 11-03-2007, 02:10 AM
  5. ACPI / Lid Closed Screen Blank
    By TheGreatVirus in forum OLD Newbie Area
    Replies: 5
    Last Post: 09-10-2007, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •