Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: wireless problem after updating

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default wireless problem after updating

    hi all
    i have a problem after updating or upgrading to r2 the wireless stop working
    the card type is Internal Intel Corporation PRO/Wireless 3945ABG
    any help
    are there any packages to download to make it work?
    Last edited by mesmar; 11-30-2010 at 06:15 AM.

  2. #2
    Junior Member
    Join Date
    Aug 2010
    Posts
    51

    Default Re: wireless problem after updating

    After you have run /etc/init.d/wicd start and explore K Menu -> Internet -> WICD Network Manager do you see the the wireless network?

    Also try run iwlist wlan0 scan and if you see the network or not.

    I hope this helps somewhat

  3. #3
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default Re: wireless problem after updating

    After you have run /etc/init.d/wicd start and explore K Menu -> Internet -> WICD Network Manager do you see the the wireless network?
    i have tried that but nothing no wireless network
    i will try the other option to see if it wworks or no

  4. #4
    Just burned his ISO
    Join Date
    Nov 2010
    Location
    Where ever there's free Wifi.
    Posts
    8

    Default Re: wireless problem after updating

    If you can connect to the network with an Ethernet connection but not through the wifi you could try 'ifconfig wlan0 up'.

    I read on a Ubuntu forum post when I was researching this problem originally that sometimes an update will turn off the wireless interface if it cant find a wireless network to connect to. It went on to explain that wifi networks with wep/wpa where also considered networks it couldn't connect to because it didn't have the pass code (even if you'd connected to that AP in the past).

    I have no clue if this is true or not. It seemed a little far fetched to me, but the command worked so I was happy.

    GL
    David

  5. #5
    Junior Member
    Join Date
    Aug 2010
    Posts
    51

    Default Re: wireless problem after updating

    Hmm and is the network hidden (requires BSSID)? If the network isnt hidden you should atleast be able to see it.

    When you run the lspci command whats the output? Sure the drivers are installed for the device?

  6. #6
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default Re: wireless problem after updating

    the network is not hidden
    the result for the command
    00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
    00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
    00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
    00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
    00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
    00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
    02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller (rev 14)
    03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    0a:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
    0a:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default Re: wireless problem after updating

    also these for lsmod
    lsmod
    Module Size Used by
    ipv6 215277 10
    i915 249903 3
    drm_kms_helper 23663 1 i915
    drm 132180 4 i915,drm_kms_helper
    sbs 8489 0
    hed 1147 0
    sbshc 2608 1 sbs
    acpi_cpufreq 5065 1
    mperf 891 1 acpi_cpufreq
    cpufreq_stats 3073 0
    cpufreq_conservative 7564 0
    cpufreq_performance 638 0
    cpufreq_powersave 634 0
    cpufreq_ondemand 6994 2
    freq_table 2007 3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
    iptable_filter 884 0
    ip_tables 9231 1 iptable_filter
    x_tables 10782 2 iptable_filter,ip_tables
    parport_pc 18091 0
    lp 7036 0
    parport 24431 2 parport_pc,lp
    snd_hda_codec_si3054 2922 1
    snd_hda_codec_realtek 189775 1
    snd_hda_intel 18438 0
    snd_hda_codec 56424 3 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda _intel
    snd_hwdep 4642 1 snd_hda_codec
    joydev 7824 0
    snd_pcm_oss 33635 0
    arc4 1046 2
    snd_mixer_oss 12386 1 snd_pcm_oss
    ecb 1565 2
    snd_pcm 57162 4 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec,s nd_pcm_oss
    iwl3945 153031 0
    pcmcia 30613 0
    rtc_cmos 7838 0
    rtc_core 11455 1 rtc_cmos
    rtc_lib 1534 1 rtc_core
    snd_seq_dummy 1023 0
    iwlcore 169619 1 iwl3945
    mac80211 207141 2 iwl3945,iwlcore
    snd_seq_oss 23301 0
    video 15550 1 i915
    output 1296 1 video
    snd_seq_midi 3720 0
    cfg80211 120768 3 iwl3945,iwlcore,mac80211
    rfkill 12316 1 cfg80211
    snd_rawmidi 14559 1 snd_seq_midi
    option 12554 0
    wmi 5970 0
    usb_wwan 6908 1 option
    snd_seq_midi_event 4312 2 snd_seq_oss,snd_seq_midi
    tifm_7xx1 3598 0
    tifm_core 3556 1 tifm_7xx1
    snd_seq 39714 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
    usbserial 26240 2 option,usb_wwan
    yenta_socket 20170 0
    psmouse 32227 0
    serio_raw 3352 0
    pcmcia_rsrc 8800 1 yenta_socket
    pcmcia_core 10644 3 pcmcia,yenta_socket,pcmcia_rsrc
    snd_timer 14958 2 snd_pcm,snd_seq
    snd_seq_device 4173 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
    snd 38829 13 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda _intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mix er_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd _timer,snd_seq_device
    iTCO_wdt 8717 0
    intel_agp 24756 2 i915
    iTCO_vendor_support 1441 1 iTCO_wdt
    shpchp 27915 0
    agpgart 22961 3 drm,intel_agp
    mac_hid 2425 0
    evdev 6681 10
    soundcore 4271 1 snd
    snd_page_alloc 5477 2 snd_hda_intel,snd_pcm
    ata_generic 2319 0
    pata_acpi 2316 0
    sky2 43624 0
    fuse 52129 1

  8. #8
    Junior Member
    Join Date
    Aug 2010
    Posts
    51

    Default Re: wireless problem after updating

    Hmm based on that output the 03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02) the drivers are installed.

    Well if you have ensured the device is active (switched on) and the drivers are there i dont see why u cant see the wireless Maybe need to try another wireless adapter driver but I cannot assist further i dont think. Sorry I couldnt help man.

  9. #9
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default Re: wireless problem after updating

    thnx for ur help man

  10. #10
    Junior Member
    Join Date
    Jan 2010
    Posts
    36

    Default Re: wireless problem after updating

    afer along google searching i get to the solution

    wget http://intellinuxwireless.org/iwlwif...-15.32.2.9.tgz
    then tar -xvzf iwlwifi-3945-ucode-15.32.2.9.tgz
    then
    # sudo cp iwlwifi-3945-ucode-15.32.2.9/iwlwifi-3945-2.ucode /lib/firmware/
    reboot
    now wireless is working

Page 1 of 2 12 LastLast

Similar Threads

  1. Updating BT4
    By MassAppeal in forum Beginners Forum
    Replies: 3
    Last Post: 02-02-2010, 01:03 PM
  2. problem with updating usb drive
    By *YAPP* in forum OLD BackTrack 4 Software Related Issues
    Replies: 8
    Last Post: 08-20-2009, 12:47 PM
  3. Problem updating Milw0rm via Fast-Track
    By imported_mobychien in forum OLD BT3final Support
    Replies: 4
    Last Post: 02-23-2009, 06:03 PM
  4. Problem updating/compiling Aircrack-ng?
    By sykick in forum OLD Newbie Area
    Replies: 10
    Last Post: 09-27-2007, 10:46 AM
  5. updating
    By ats1080 in forum OLD LiveCD Support
    Replies: 5
    Last Post: 09-14-2007, 07:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •