Results 1 to 2 of 2

Thread: [ERROR] err:winediag:X11DRV_WineGL_InitOpenglInfo

  1. #1
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    1

    Default [ERROR] err:winediag:X11DRV_WineGL_InitOpenglInfo

    Hey guys,

    I have a problem. I'm not sure which drivers I need to get. I keep getting this error in wine;

    "err:winediag:X11DRV_WineGL_InitOpenglInfo The Mesa OpenGL driver is using software rendering, most likely your OpenGL drivers haven't been installed correctly"

    I have been to the WINE support IRC channel and Googled my brains out for the past 3 days to no avail. The guys at wine don't believe it's a WINE issue and directed me to go to my distro support.

    lspci:

    Code:
    00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
    00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
    00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
    00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
    00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
    00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
    00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
    02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
    xorg.conf: (I have tried; Driver "vesa", Driver "intel", Driver "i915", Driver "i810", Driver "intel0")

    vesa is great but gives me that error I said at the start and intel, when running wine applications and glxgears crashes X (Freezes the screen).

    Code:
    Section "Device"
           Identifier "Configured Video Device"
            Driver "vesa"
    EndSection
    
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 160
     EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
            DefaultDepth 24
            Subsection "Display"
                 Depth 24
                 Modes "1280x1024" "1024x768"
            EndSubsection
    EndSection
    glxinfo | grep direct:

    Code:
    direct rendering: Yes
    If you need any more information, just ask. Any help is greatly appreciated.

    Thank you.

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: [ERROR] err:winediag:X11DRV_WineGL_InitOpenglInfo

    Let me google that for you (Takes like 10 seconds to type the whole error message)
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. Replies: 3
    Last Post: 10-18-2010, 11:00 PM
  2. Bt- 4 serieas problem error error
    By lenien in forum Beginners Forum
    Replies: 2
    Last Post: 01-18-2010, 06:52 PM
  3. NTOP **WARNING** gzflush error -2(stream error)
    By Larika in forum OLD BackTrack 4 (pre) Final
    Replies: 8
    Last Post: 07-18-2009, 07:41 PM
  4. SEND L3 ERROR/Ettercap error?
    By sunking in forum OLD Newbie Area
    Replies: 7
    Last Post: 07-01-2009, 10:31 PM
  5. metasploit -msfupdate error - svn : PROFIND request error
    By aisketui in forum OLD BT3beta Software related issues
    Replies: 2
    Last Post: 02-11-2009, 03:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •