Results 1 to 6 of 6

Thread: Newer Python?

  1. #1
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Newer Python?

    Note the following request is based on BT 4R1.

    Could we get a version of Python newer than 2.5.2? Perhaps 2.6.5 which is used in Ubuntu 10.04.1 LTS.
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  2. #2
    Senior Member kidFromBigD's Avatar
    Join Date
    Jan 2010
    Location
    Texas
    Posts
    159

    Default Re: Newer Python?

    +1
    Still, I was able to download from source, compile and was up and running rather quickly:
    Download from here:
    http://python.org/ftp/python/2.7/Python-2.7.tgz
    Code:
    tar xzf Python-2.7.tgz
    cd Python-2.7
    ./configure
    make
    make install
    Apologies if you already know how to do this. Just wanted it documented for the other BT n00bs.
    Last edited by kidFromBigD; 11-24-2010 at 04:10 PM. Reason: Lacking in my foo...
    You. Are. Doing. It. Wrong.
    -Gitsnik

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Newer Python?

    This would likely cause problems in other tools that require specific versions of python.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4
    Senior Member kidFromBigD's Avatar
    Join Date
    Jan 2010
    Location
    Texas
    Posts
    159

    Default Re: Newer Python?

    Yes, correct.
    In fact, it temporarily broke my pyrit install until I circled back to build & install anew.
    Thanks for noting that.
    You. Are. Doing. It. Wrong.
    -Gitsnik

  5. #5
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default Re: Newer Python?

    At this stage of bt4 upgrading python would be really difficult. There is more than you think which is dependent on python 2.5. The next major release will have a python upgrade and a ruby upgrade

  6. #6
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Re: Newer Python?

    Thanks for the news purehate.
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

Similar Threads

  1. Compile/ Upgrade to newer kernel
    By hololight in forum Beginners Forum
    Replies: 1
    Last Post: 04-17-2010, 10:30 AM
  2. Replies: 1
    Last Post: 01-22-2010, 12:45 PM
  3. Ati FGLRX for notebooks and newer PCs (BT3)
    By Bohdan Turkynewych in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-04-2009, 01:27 AM
  4. New to linux, newer to BT
    By GunMonkey in forum OLD Newbie Area
    Replies: 3
    Last Post: 02-13-2008, 04:18 AM
  5. Trying to install newer version of cairo into BT2
    By imported_pentester in forum OLD Newbie Area
    Replies: 6
    Last Post: 12-13-2007, 03:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •