Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

Hybrid View

  1. #1
    Senior Member
    Join Date
    Jan 2010
    Posts
    173

    Default Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    Mod Edit: Do not double post. Use sensible thread titles.


    Been running BT4 R2 for a few hours and it seems sweet, rtl8187 alpha and deal extreme 2000mw usb on vmware are working perfect and response times are great have been using BT4 Final due to the fact of it being so stable but will now be moving over to R2.

    Fast, vmware seems to work smooth, ferns wifi cracker is working fine too.

    Regards Dee

    Thanks to all the guys who have put the time and energy into BT keep up the good work.

    Interface Chipset Driver
    OOOps!
    After reboot all i get is this now any ideas?

    wlan0 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    (monitor mode enabled on mon0)
    Last edited by Archangel-Amael; 11-22-2010 at 08:44 PM.

  2. #2
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: Bt 4 R2

    i hope you can solve it quickly, i'm downloading it already with intention to install it, and i'm also using a rtl8187 (500mW)..

    Good luck, and please keep us updated..

    Thanx!

  3. #3
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Bt 4 R2

    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Posts
    173

    Default Re: Bt 4 R2

    Sorry Archangel for the double. still cant get to grips with the forum thing.

    just found this:

    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up


    all the others dont work but this seems to and work upon reboot.

    regards Dee
    Last edited by pentest09; 11-22-2010 at 09:15 PM.

  5. #5
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: Bt 4 R2

    Quote Originally Posted by pentest09 View Post
    just found this:

    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    You need to this in every reboot?

    Thanx!

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Posts
    173

    Default Re: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    Any way for this to be automated to survive reboot? BT4 Final never had any problems with the drivers how can this be resolved.?
    Regards Dee

  7. #7
    Developer muts's Avatar
    Join Date
    Jan 2006
    Posts
    272

    Default Re: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    From our testing, this seems like a VMWare issue ... no resolution in sight. We will update
    Wireless Drivers - BackTrack Linux when this gets fixed.

    In our testing, we found this problem to STILL occur in more recent compat-wireless releases, but less often.

  8. #8
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    Quote Originally Posted by muts View Post
    From our testing, this seems like a VMWare issue ...
    So, this is only a VMWare issue? I'll be using dual-boot..

    Thanx!

  9. #9
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    1

    Default Re: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    im alittle on the frustrated side... i have a rtl8187 in my laptop and its been a pain getting it to work with this. i managed the 1st time by i guess just plain luck... i messed up on one part n closed out program to take a look back at the you tube vid to see where i went wrong... upon getting back in it kept giving me unknown error 132.. i found this thread in my search for help i did the
    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    thing and the 1st time it worked...i was happy n got to the airmon-ng start wlan0 and well was getting very little data packets from only 4 of the 12 listed signals 2 of which were my own... so i shut down to look up sum more stuff... upon returning and retyping this it didnt work when i typed ifconfig wlan0 up it said unknown error 132.
    i tried a rtl8188su but wont work with it and a wg111t and wont list that either.

    ive tried restarting the laptop several time and retyping all that stuff but still no luck any suggestions?

  10. #10
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    9

    Default Re: Bt 4 R2 RTL8187 rtl8187 - [phy0]SIOCSIFFLAGS: Unknown error 132

    For those using a Mac w/ vmware fusion, vmware has pushed out an update (3.1.2) that appears to have fixed the problem. I haven't had the opportunity to test out packet injection, but so far the card isn't being shut off immediately after being plugged in.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •