Results 1 to 9 of 9

Thread: WEP attack problem - Get no ARP requests

  1. #1
    Junior Member Kungen's Avatar
    Join Date
    Feb 2010
    Posts
    81

    Default WEP attack problem - Get no ARP requests

    Evening everyone!

    Have a little trouble with getting some ARP requests when i try to break my D-Links (DIR-600) WEP encryption. My chosen password have a length of 13letters.

    I have tried with my two networkd USB cards:
    * Netgear WG111v3
    * Alfa (The H version)
    * Inuilt iwl3945 Intel card

    The range from the router is 2meters.

    I have done a test with aireplay-ng and it says that injection and everything works when i use two network cards on the same time to test em out. When i used BT3 a longtime ago on one of my other D-link routers (DGL-4300) it went fine when cracking the wep key and getting ARP requests.


    I have tested with g0tmilkw wiffy.sh and it tugging for about 4-5min before it says something went wrong and i have tried to do it manually to. Both -3 attack and the -4 chopchop attack, still no more luck, the only thats increase except the packets is the ACK "packets" or what you call them when i try to do a deauth/fake autechtion to about 300-700.

    Its a normal "open" key and no pre-shared wep key.


    Anyone have any ideas?
    PS: I followed the attack examples from the aircrack website, both ARP and chopchop attack.


    Regards
    Jacob

  2. #2
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: WEP attack problem - Get no ARP requests

    Have you tried a fragmentation attack, and then inject the collected packet to collect IV's? Also, why don't you use Gerix-Wifi-Cracker that already comes with BT4 tools suite? It's more than complete to use in WEP attacks, and pretty much user friendly. You can start with frag. attack, once the packet is ready, start ARP request? (not necessary), then inject the packet until you have enough IV's.

    I've heard somewhere some new routers come protected against wep injection, but i'm not even sure this is true..

    Good luck!

  3. #3
    Junior Member Kungen's Avatar
    Join Date
    Feb 2010
    Posts
    81

    Default Re: WEP attack problem - Get no ARP requests

    Hi skor78!

    I tried the software u recommended me but still no luck.
    I start to associate with the AP faked and then fragmention, Create ARP packet, and when i try to inject it it says No such file or directory, maybe i need to read more packets maybe but still no luck with either chopchop or fragmention.

    The last thing you wrote is that possible? Wouldnt that screq up many old USD network cards if they change the WEP standard, it must still be injectable right?

  4. #4
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    1

    Default Re: WEP attack problem - Get no ARP requests

    you can all time check your mac. tipe " ifconfig " in console look if fits to fake mac, if not skip ifconfig wlan0 down, just type first" ifconfig (to look your mac)" copi mac, then write airodump wlan0 then use your mac to -h, some times you must wait to get arp, 1m 5m 10m, depends .sorry bad english. or run backtrack in VMware Workstation

  5. #5
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: WEP attack problem - Get no ARP requests

    Like i said, i've heard somewhere, but never seen such thing, might be true, or might just be another urban myth..

    No such file or directory? hummm.. Are you sure the frag attack created a packet, read closely the result, i think you might not have been successful in the frag attack. it should say something close to "successful created 1500bytes of a packet", also try to run chop-chop while running frag attack, sometimes it helps. Oh and another thing! LOOK at the BSSID from the packet you use to frag and chop-chop attack, it might not be one from your router.

  6. #6
    Junior Member
    Join Date
    Nov 2010
    Posts
    27

    Default Respuesta: Re: WEP attack problem - Get no ARP requests

    Quote Originally Posted by skor78 View Post

    I've heard somewhere some new routers come protected against wep injection, but i'm not even sure this is true..

    Good luck!
    If you wanna test that question, connect to your wireless and make a ping scan. With that, if you make a ping to an inexistent host at the wireless behind that address, usually that force the ap to release at least an arp. With that arp, test if injects.

    Pentrite

  7. #7
    Junior Member Kungen's Avatar
    Join Date
    Feb 2010
    Posts
    81

    Default Re: Respuesta: Re: WEP attack problem - Get no ARP requests

    Quote Originally Posted by bymetla View Post
    you can all time check your mac. tipe " ifconfig " in console look if fits to fake mac, if not skip ifconfig wlan0 down, just type first" ifconfig (to look your mac)" copi mac, then write airodump wlan0 then use your mac to -h, some times you must wait to get arp, 1m 5m 10m, depends .sorry bad english. or run backtrack in VMware Workstation
    Will give it a try after my work!

    Quote Originally Posted by skor78 View Post
    Like i said, i've heard somewhere, but never seen such thing, might be true, or might just be another urban myth..

    No such file or directory? hummm.. Are you sure the frag attack created a packet, read closely the result, i think you might not have been successful in the frag attack. it should say something close to "successful created 1500bytes of a packet", also try to run chop-chop while running frag attack, sometimes it helps. Oh and another thing! LOOK at the BSSID from the packet you use to frag and chop-chop attack, it might not be one from your router.
    How many packets do i need to be able to create this inject packet? Becouse even if it had read 100 or 10000packets it only says when i click on the button that i want to use the infected packet that it cannot be find/not exist in a white command window.

    Quote Originally Posted by pentrite View Post
    If you wanna test that question, connect to your wireless and make a ping scan. With that, if you make a ping to an inexistent host at the wireless behind that address, usually that force the ap to release at least an arp. With that arp, test if injects.

    Pentrite
    Im not quiet sure i understand you.. Do you mean that i shall ping another computer in my wireless network that is already connected to it? Or you just mean a website?
    PS: I want to do this without clients so i dont have any conencted to it right now.

  8. #8
    Junior Member
    Join Date
    Nov 2010
    Posts
    27

    Default Respuesta: Re: Respuesta: Re: WEP attack problem - Get no ARP requests

    Quote Originally Posted by Kungen View Post

    Im not quiet sure i understand you.. Do you mean that i shall ping another computer in my wireless network that is already connected to it? Or you just mean a website?
    PS: I want to do this without clients so i dont have any conencted to it right now.
    Ok, for example, suppose that you have two computers, one conected and with ip and other associated and sniffing looking for an arp packet. Your connected computer have the ip "ip_address". With your connected computer make an ping scan. If youur connected computer make a ping to an ip address for example, between your gateway and your "ip address", that means nobody behind, no host behind, your router release at least one arp. And the other will catch it.

    Pentrite.

  9. #9
    Member skor78's Avatar
    Join Date
    Jul 2009
    Posts
    140

    Default Re: Respuesta: Re: WEP attack problem - Get no ARP requests

    Quote Originally Posted by Kungen View Post
    How many packets do i need to be able to create this inject packet? Becouse even if it had read 100 or 10000packets it only says when i click on the button that i want to use the infected packet that it cannot be find/not exist in a white command window.
    I'm not sure if you do not understand me, or i don't understand you..
    If you're using Gerix, sequence is config. tab, if managed mode turn on monitor mode, scan networks, select it, wep tab, start snif, acossiate with ap, frag attack, create arp, inject arp.
    Are you missing any step?

    Quote Originally Posted by Kungen View Post
    PS: I want to do this without clients so i dont have any conencted to it right now.
    Quote Originally Posted by pentrite View Post
    Ok, for example, suppose that you have two computers....
    Thanx for the explaining the trick, but it was a funny start.

    Cheers.
    Last edited by skor78; 11-12-2010 at 01:51 AM.

Similar Threads

  1. Replies: 25
    Last Post: 08-13-2010, 01:03 PM
  2. ChopChop attack problem - invalid packet
    By xtomiii in forum OLD Newbie Area
    Replies: 0
    Last Post: 05-06-2009, 12:26 AM
  3. Aircrack problem "attack mode already specified"
    By XxBJDxX in forum OLD Newbie Area
    Replies: 2
    Last Post: 11-09-2008, 02:48 PM
  4. Clientless WEP attack problem
    By fido13uk in forum OLD Newbie Area
    Replies: 7
    Last Post: 02-09-2008, 03:57 AM
  5. Not Getting ARP requests in No client attack
    By musik4u66 in forum OLD Newbie Area
    Replies: 3
    Last Post: 01-03-2008, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •