Hello All,

I have a problem with the airoscript built in to BT 2. I use a ubiquity 300mw atheros based card. I modified the parameters in airoscript to fit my card.then i enter the following:

bt home # airmon-ng start wifi0


Interface Chipset Driver

wifi0 Atheros madwifi-ng
eth1 Centrino b/g ipw2200
ath0 Atheros madwifi-ng VAP (parent: wifi0) (monitor mode enabled)


bt home # airoscript.sh

#######################################
### Select your interface ###

1) eth1
2) ath0
#?2

#######################################
### What do you want to do? ###
### 1) Scan - Scan for target ###
### 2) Select - Select target ###
### 3) Attack - Attack target ###
### 4) Crack - Get target key ###
### 5) Config - Connect to target ###
### 6) Fakeauth- Auth with target ###
### 7) Deauth - Deauth from target ###
### 8) Reset - Reset interface ###
### 9) Monitor - Airmon-ng device ###
###10) Quit - Quits airoscript ###
###11) Airomatic- step 1,2,3 linked ###
###12) ChangeMac- Change your MAC ###
1) 1 3) 3 5) 5 7) 7 9) 9 11) 11 13) 13 15) 15
2) 2 4) 4 6) 6 8) 8 10) 10 12) 12 14) 14
#?1

Then i answer the questions as requested by the script. When airodumps starts, it starts and exits immediatly and comes up with the following screen:

### Airodump closed, select a target###

when i want to select the target, the following is displayed:

######################################
### Select Target from this list ###

# MAC CHAN SECU POWER #CHAR SSID

/usr/local/bin/airoscript.sh: line 154: /home/root/dump-02.txt: No such file or directory

### Select target ###

This is understandable as airodump did not run properly. But why does airodump exit immediatly?

I am not sure what the problem is here. I also tried the newest version of the script but the result is the same.

Kismet is working fine with this card. Anyone any ideas?

Thanks in advance