Hello everyone,

I am using apache on backtrack.
Everything worked fine, but when i want to redirect port 80 to 8080,
I could not connect to my apache server anymore.
I tried myipaddress:8080/index.html --> The requested URL /index.html was not found on this server.
I also portforwarded port 8080.
Here are the steps I took :

/etc/apache2/ports.conf --> I changed the listen port to 8080 and also the Virtualhost to that port.

PHP Code:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    
# SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    
Listen 443
</IfModule
After that I changed also the VirtualHost statement in /etc/apache2/sites-enabled/000
to port 8080.

PHP Code:
<VirtualHost *:80>
    
ServerAdmin webmaster@localhost
    
    DocumentRoot 
/var/www/
    <
Directory />
        
Options FollowSymLinks
        AllowOverride None
    
</Directory>
    <
Directory /var/www/>
        
Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow
,deny
        allow from all
    
</Directory>

    
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <
Directory "/usr/lib/cgi-bin">
        
AllowOverride None
        Options 
+ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow
,deny
        Allow from all
    
</Directory>

    
ErrorLog /var/log/apache2/error.log

    
# Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    
LogLevel warn

    CustomLog 
/var/log/apache2/access.log combined

    Alias 
/doc"/usr/share/doc/"
    
<Directory "/usr/share/doc/">
        
Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny
,allow
        Deny from all
        Allow from 127.0.0.0
/255.0.0.0 ::1/128
    
</Directory>

</
VirtualHost