Results 1 to 3 of 3

Thread: xorg.conf changes arent saved

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    11

    Default xorg.conf changes arent saved

    hi all.

    I'm running bt4 of a usb stick after following the guide on installing bt4 persistence on a usb stick.

    my vga is a nvidia 230m. I installed the drivers found on nvidia site I also tried installing the backtrack-nvidia package. and just to make sure I formatted the capser partition and tried both cases (the nvidia site one and the backtrack-nvidia package). Anyway I try it my xorg.conf isnt saved.

    after I run nvidia-xconfig I can start x with the nvidia driver but once I reboot and start x it is started without the nvidia drivers.

    everything else gets saved and any changes I do to the system is saved except changes made to xorg.conf.

    anyone else having this problem ?!

    thanks in advance.

  2. #2
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    1

    Default Re : xorg.conf changes arent saved

    Hello,

    I have the exact same problem. Every other file gets recorded to disk except xorg.conf. It seems a default file is created on shutdown/reboot or startx, and backups are created with the name xorg.conf.yyyymmddtime. I suspect it's done in an init script but I cant find where.

    It seems related to this problem:
    Persistent Resolution - Remote Exploit Forums
    but I don't have a syslinux.cfg and grep did not return any AUTOEXEC, assuming I used it correctly.

    Any help would be really appreciated.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    4

    Smile Re: xorg.conf changes arent saved

    I can help with that (its also for everyone else looking for it).

    This is only for people that have BackTrack 4 installed on a USB drive!

    So what happens is that every time we boot a scripts gets called to auto fill in the display drivers (like in the normal live CD) to disable this we need to edit the script and stop it from overwriting our xorg.conf file every time we reboot.

    type:
    Code:
    nano /usr/bin/dexconf
    and on the first line insert exit 0 like below
    Code:
    #!/bin/sh
    exit 0
    #dexconf: Debian X server configuration file writer
    #
    ...
    We only add the exit 0 on the top, this will make the script exit as soon as its called. I know there are other options but this allows us if necessary to easily change things back to the good old (without changing a lot of other files)

    Hopes that helps ,

    ~Fritz

Similar Threads

  1. Dual Monitors - xorg.conf
    By ekisner in forum Beginners Forum
    Replies: 6
    Last Post: 02-10-2010, 04:53 AM
  2. xorg.conf looks empty ?
    By capron in forum Beginners Forum
    Replies: 6
    Last Post: 01-17-2010, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •