I just installed BT4 on my laptop and wanted to install a cisco vpn client . I am following the below steps



wget ftp://ftp.cs.cornell.edu/pub/rvr/upl...0490-k9.tar.gz
tar zxvf vpnclient-linux-4.8.00.0490-k9.tar.gz
cd vpnclient/
wget http://tuxx-home.at/projects/cisco-v...ux-2.6.22.diff
patch < vpnclient-linux-2.6.22.diff
./vpn_install



and when I am doing the above things it is giving me following error

Is the above correct [y]y

Making module
make -C /lib/modules/2.6.30.9/build SUBDIRS=/root/vpnclient modules
make[1]: Entering directory `/usr/src/linux-source-2.6.30.9'

WARNING: Symbol version dump /usr/src/linux-source-2.6.30.9/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /root/vpnclient/linuxcniapi.o
In file included from /root/vpnclient/Cniapi.h:15,
from /root/vpnclient/linuxcniapi.c:30:
/root/vpnclient/GenDefs.h:113: error: conflicting types for 'uintptr_t'
include/linux/types.h:41: error: previous declaration of 'uintptr_t' was here
make[2]: *** [/root/vpnclient/linuxcniapi.o] Error 1
make[1]: *** [_module_/root/vpnclient] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.30.9'
make: *** [default] Error 2
Failed to make module "cisco_ipsec.ko".



Please help with this