Results 1 to 2 of 2

Thread: * Need help with packet injection using ALFA AWUS036H *

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    3

    Default * Need help with packet injection using ALFA AWUS036H *

    Hi guys,
    I could really use some help here, ive been struggling to understand why im unable to get packet injection to function. I have just bought an ALFA AWUS036H usb wireless adaptor. I had previously been using a netgear WG111v2. When i came to install the ALFA linux drivers from the cd i realised that the drivers are 100% identical to the drivers i already installed for the netgear adaptor (which i sourced from the realtek website), obviously the 2 units use the same rtl8187 chipset.

    * When i plug the ALFA in, i type iwconfig and it shows up as wlan0.
    * when i type airmon-ng start wlan0 it shows the chipset as rtl8187 and the driver as r8187
    * i have been able to connect to the internet using network manager
    *airodump seems to work ok, can pick up a few bssids

    so this brings me to the problems i am up against:

    when i try to use aireplay-ng with -9 (test injection)... i get no ''injection working'' message and a 0/30 0% message indicating that no injection took place

    when i tried to use aireplay-ng -3 (arp replay) having already used macchanger to spoof my mac address to that of another node on the network... it read a lot of packets (i stopped it at 2000) but returned 0 arp requests and also 0 packets sent indicating that no injection is taking place

    i have been trying these tests on na wpa2/tkip network although if i understand correctly that shouldnt affect the ability to inject packets

    can anyone suggest any configuration changes or things that i can check that might tell why im not able to use this feature?

    thanks very much

    OCyder


    ive been following various guides and tutorials on youtube and on here and experimenting with the aircrack tool suite.

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: * Need help with packet injection using ALFA AWUS036H *

    You need to keep reading the documentation at aircrack-ng.org because it appears you do not have full understanding of what you are trying to do.

    Further I don't see why you would install drivers for cards that are already included by default in BT.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Similar Threads

  1. Injection parziale con ALFA AWUS036H
    By new.diablo in forum Supporto Hardware
    Replies: 5
    Last Post: 08-30-2010, 05:52 PM
  2. Packet injection doesn't increase IVs capture speed (Alfa AWUS036H 1W)
    By verysofttoiletpaper in forum Beginners Forum
    Replies: 7
    Last Post: 04-12-2010, 05:49 AM
  3. packet injection with AWUS036H
    By kidshoalin in forum OLD Newbie Area
    Replies: 9
    Last Post: 03-09-2009, 07:05 AM
  4. Replies: 18
    Last Post: 04-22-2008, 07:31 PM
  5. Injection Problem / Alfa AWUS036H
    By goon123 in forum OLD BackTrack v2.0 Final
    Replies: 9
    Last Post: 09-26-2007, 07:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •