Page 6 of 6 FirstFirst ... 456
Results 51 to 53 of 53

Thread: Update script for bt4 (update.sh)

  1. #51
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    11

    Default Re: Update script for bt4 (update.sh)

    Hi there,

    I have a weird problem with Firefox 4 and BT R2.

    Firefox was not running while running this script.

    After punching in @root: bash btupdate.sh -F

    Code:
    ################################################################
                     Bactrack Update Utility
                  (C)opyright 2010 Scamentology
           Update report for Sun Apr 17 20:16:20 IST 2011
    ################################################################
    -------------------------------------------------------
    Something went wrong. Open konsole and run - firefox -v
    
    System Info - Linux bt 2.6.35.8 i686
    ################################################################
    root@bt:~# firefox -v
    Mozilla Firefox 3.0.15, Copyright (c) 1998 - 2009 mozilla.org

  2. #52
    Just burned his ISO
    Join Date
    Feb 2010
    Location
    Central, Ohio
    Posts
    5

    Default Re: Update script for bt4 (update.sh)

    Here is the error that I get when I try to run w3af_gui or w3af_console:

    Error: Python 2.5 was found and Python = 2.6 is required.


    Thanks....

  3. #53
    Senior Member
    Join Date
    May 2010
    Posts
    198

    Default Re: Update script for bt4 (update.sh)

    Quote Originally Posted by gray_hat View Post
    Hi there,

    I have a weird problem with Firefox 4 and BT R2.

    Firefox was not running while running this script.

    After punching in @root: bash btupdate.sh -F

    Code:
    ################################################################
                     Bactrack Update Utility
                  (C)opyright 2010 Scamentology
           Update report for Sun Apr 17 20:16:20 IST 2011
    ################################################################
    -------------------------------------------------------
    Something went wrong. Open konsole and run - firefox -v
    
    System Info - Linux bt 2.6.35.8 i686
    ################################################################
    root@bt:~# firefox -v
    Mozilla Firefox 3.0.15, Copyright (c) 1998 - 2009 mozilla.org
    Hmmmm...
    Try the commands manually and let me know what happens
    Do them one at a time and print out the errors if you have the time.

    mkdir /root/ffinstall
    cd /root/ffinstall
    wget http://download.mozilla.org/?product...nux&lang=en-US
    tar -C /opt -xvf /root/ffinstall/firefox-*
    ln -s /opt/firefox/firefox /usr/bin/firefox
    ln -s /opt/firefox/firefox /usr/bin/firefox4
    rm -rf /root/ffinstall

    Thanks for reporting this.

    Quote Originally Posted by korang View Post
    Love the script.

    Anyone else run into the issue when w3af is updated that it complains about the python version?
    Yes I forgot to mention - You have to update to python 2.6 to use the updated w3af. I will be making this an optional update in the next release.

    apt-get remove w3af
    rm -rf /pentest/web/w3af
    apt-get install w3af
    Last edited by Scamentology; 04-20-2011 at 03:31 AM.
    "Never do anything against conscience -- even if the state demands it."
    -- Albert Einstein

Page 6 of 6 FirstFirst ... 456

Similar Threads

  1. simple update script for key pentest tools
    By brtw2003 in forum Experts Forum
    Replies: 3
    Last Post: 09-04-2010, 10:17 PM
  2. Update Script
    By alienstargate in forum OLD BackTrack 3 Final
    Replies: 0
    Last Post: 02-25-2010, 03:12 PM
  3. update-milw0rm script menu-item
    By Archangel-Amael in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 4
    Last Post: 07-07-2009, 06:14 PM
  4. updated update script
    By bofh28 in forum OLD BT3beta General
    Replies: 16
    Last Post: 02-29-2008, 06:38 AM
  5. Update all script BT2
    By alienstargate in forum OLD BackTrack v2.0 Final
    Replies: 2
    Last Post: 02-13-2008, 12:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •