Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Karma

Hybrid View

  1. #1
    Junior Member jonah_15's Avatar
    Join Date
    Jan 2010
    Posts
    25

    Default Karma

    Has anyone managed to get Karma running without issues on BT2.0? This tool is great but i've always had problems getting it running. On my installation of BT2.0 I get Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument. When I try and start the Karma script.

    I'm sure this is a driver issue and not just the card not switching into monitor mode.

    I have a the same hardware and wireless card running Karma on Fedora4 without any problems.

    Any ideas?

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    20

    Default

    run airmon-ng , you will see wifi0 with your eth1 internal card and ath0

    run

    airmon start wifi0

    then run iwconfig , you will see another interface ( ath1 )

    run the karma with it , it will work

  3. #3
    Junior Member jonah_15's Avatar
    Join Date
    Jan 2010
    Posts
    25

    Default

    Thanks for the response, but I still have the same problem after running the airmon-ng commands. Changed karma.xml to specify ath1 as the interface but when I run the file I get the same error (this time for ath1)

    SIOCSIFHWADDR: Invalid argument
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath1 ; Invalid argument.


    I think my interfaces all look ok, I can see that ath1 is in monitor mode.

    bt sbin # airmon-ng start wifi0


    Interface Chipset Driver

    wifi0 Atheros madwifi-ng
    eth1 Centrino b/g ipw2200
    ath0 Atheros madwifi-ng VAP (parent: wifi0)
    ath1 Atheros madwifi-ng VAP (parent: wifi0) (monitor mode enabled)

  4. #4
    Junior Member
    Join Date
    Jan 2010
    Posts
    55

    Default

    made some progress. you'll notice Before and After. I put those in to debug where I'm getting hung up. As soon as i hit control-c, the after part is printed to screen.

    bt karma-20060124 # ./bin/karma etc/karma-scan.xml
    Starting KARMA...
    Loading config file etc/karma-scan.xml
    ACCESS-POINT is running
    DNS-SERVER is running
    DHCP-SERVER is running
    Delivering judicious KARMA, hit Control-C to quit.
    before
    SIOCSIFHWADDR: Invalid argument
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.
    after
    /pentest/wireless/karma-20060124/modules/servers/DhcpServer/dhcp.rb:127:in `initialize': No such file or directory - /tmp/karma5411.0 (Errno::ENOENT)
    from /pentest/wireless/karma-20060124/modules/servers/DhcpServer/dhcp.rb:127:in `stop'
    from ./bin/../modules/loader.rb:212:in `stop'
    from ./bin/../modules/loader.rb:206:in `stop'
    from ./bin/../modules/loader.rb:204:in `stop'
    from ./bin/karma:59
    from ./bin/karma:58
    from ./bin/karma:64
    Here's the extra code I added for debugging... this is in .../karma-20060124/bin/karma
    # Wait for all threads to terminate or SIGINT
    puts "before"
    trap ("SIGINT") {
    puts "after"
    Karma::MODULES.each_value() {|m|
    m.stop()
    }

    exit(0)
    So basically, trap ("SIGINT") { is causing this to happen:
    SIOCSIFHWADDR: Invalid argument
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.
    I have a Senao Prism2 card, It injects nicely and is flashed to 1.7.4. iwconfig mode Managed / Monitor works fine, not sure why I'm getting the Set Mode message. Airmon-ng shows I'm in monitor mode. I even used the Karma monitor mode script which works flawlessly after creating sym links in /usr/sbin

  5. #5
    Junior Member
    Join Date
    Jan 2010
    Posts
    55

    Default

    progress: try using karma.xml instead of karma-scan. I don't get errors.

    bt karma-20060124 # ./bin/karma etc/karma.xml
    Starting KARMA...
    Loading config file etc/karma.xml
    ACCESS-POINT is running
    DNS-SERVER is running
    DHCP-SERVER is running
    POP3-SERVER is running
    FTP-SERVER is running
    [2007-04-10 23:52:39] INFO WEBrick 1.3.1
    [2007-04-10 23:52:39] INFO ruby 1.8.4 (2005-12-24) [i686-linux]
    [2007-04-10 23:52:39] INFO WEBrick::HTTPServer#start: pid=23635 port=80
    HTTP-SERVER is running
    CONTROLLER-SERVLET is running
    EXAMPLE-WEB-EXPLOIT is running
    Delivering judicious KARMA, hit Control-C to quit.
    before

  6. #6
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    7

    Default

    It must have something to do with the new madwifi and iwpriv.... I am having the same issue.

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    55

    Default

    has anyone ever got this to work?

    btw, this thread should probably be moved to specialist topics > wireless.

  8. #8
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    9

    Default Karma Patch

    Can someone go through the steps to get Karma working on BT3
    It sounds like a patch from Digininja.or is necessary.


    Thanks,

  9. #9
    Just burned his ISO
    Join Date
    Mar 2008
    Posts
    9

    Default Karma Working

    Ok, I got Karma working with the dninja patches www [dot] digininja [dot] org
    and with a little help from H D Moore's metasploit intergration scripts it works great. Let me know if you would like to see the script...

  10. #10
    Junior Member
    Join Date
    Jan 2010
    Posts
    55

    Default

    yeah, I'd love to see the script. Thanks in advance for your help!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •