Results 1 to 4 of 4

Thread: Wireless drivers not loading

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    1

    Unhappy Wireless drivers not loading

    Hi fellow BackTrack users,

    I want to crack my own network (or try so), and i googled a lot and found Backtrack.
    So I downloaded and burned the BackTrack v3 Live cd, and it worked (although i had to use the KDE vesa mode to get an image).

    My problem is : it doesn't detect my wireless card! After some searching i found out this has to do with not being supported. I also found how to fix this.

    What I did:
    Code:
    cd Desktop
    #i downloaded these drivers, as they will make this card compitable to BackTrack its tools
    tar -xzf iwlwifi-5000-ucode-8.24.2.12.gz
    
    mv iwlwifi-5000-ucode-8.24.2.12/iwlwifi-5000-2.ucode /lib/firmware/
    #i dont know what the next does, and it also fails
    modprobe iwlagn
    So it copies the right driver to the firmware folder, i know it will be gone at the next reboot but if this works i just run these few commands every boot.

    But not it still doesn't detect my wireless card after doing this, do i need to reload or install it or something? If so please tell me how.

    I am using a laptop, booting the BackTrack v3 Live cd (working correct), and my wireless card is Intel 5100 AGN.

    Sorry for the noobish questions, but im a bit new to Linux, and as I'm not (yet) planning to work a lot with it i just want this to be fixed. It isn't even required for me to understand all the commands, as long as it works.

    I hope someone can help me out, would really appreciate it

    Thanks!

    Hi fellow BackTrack users,

    I want to crack my own network (or try so), and i googled a lot and found Backtrack.
    So I downloaded and burned the BackTrack v3 Live cd, and it worked (although i had to use the KDE vesa mode to get an image).

    My problem is : it doesn't detect my wireless card! After some searching i found out this has to do with not being supported. I also found how to fix this.

    What I did:
    Code:
    cd Desktop
    #i downloaded these drivers, as they will make this card compitable to BackTrack its tools
    tar -xzf iwlwifi-5000-ucode-8.24.2.12.gz
    
    mv iwlwifi-5000-ucode-8.24.2.12/iwlwifi-5000-2.ucode /lib/firmware/
    #i dont know what the next does, and it also fails
    modprobe iwlagn
    So it copies the right driver to the firmware folder, i know it will be gone at the next reboot but if this works i just run these few commands every boot.

    But not it still doesn't detect my wireless card after doing this, do i need to reload or install it or something? If so please tell me how.

    I am using a laptop, booting the BackTrack v3 Live cd (working correct), and my wireless card is Intel 5100 AGN.

    Sorry for the noobish questions, but im a bit new to Linux, and as I'm not (yet) planning to work a lot with it i just want this to be fixed. It isn't even required for me to understand all the commands, as long as it works.

    I hope someone can help me out, would really appreciate it

    Thanks!
    Last edited by Archangel-Amael; 10-07-2010 at 11:14 AM.

  2. #2
    Good friend of the forums espreto's Avatar
    Join Date
    Mar 2010
    Location
    Brazil
    Posts
    303

    Default Re: Wireless card not detected!

    Why create two topics for the same doubts??

    Download the final version of backtrack and be happy!
    It has an extensive support wi-fi cards.

    Go to link:

    Downloads | BackTrack Linux - Penetration Testing Distribution

    Regards,
    (gdb) disass m(y_br)ain

    ®

  3. #3
    Just burned his ISO
    Join Date
    Oct 2010
    Location
    Uk
    Posts
    3

    Default Re: Wireless card not detected!

    Just some advice pietjepuk12345

    1 dont go creating multiple threads for the same issue
    and
    2 make sure you try to take steps in solving the issue your self first

    you obviously did some form of research to find the steps that you tried but no more than 10 mins on google i think

    as espreto said download a new stable version eg. BackTrack 4 R1 or BackTrack 4 Final Release and your problems (in most situations) go away

    you can also visit the forums hardware compatibility lists or seach to see if anyone has the same bug as you or a bug fix
    HardWare Compatibility List
    BackTrack Bugs
    BackTrack Fixes

    try all these things before posting ok

    also say you have done these things or you will get the same (potentialy unfair) heckling you have received from me

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Wireless drivers not loading

    Quote Originally Posted by compoundguy View Post
    also say you have done these things or you will get the same (potentialy unfair) heckling you have received from me
    Just typing the words "I have searched" is not really gonna cut it. We can easily see right past that. Further we do not allow heckling here, we advise our members to use the search feature, before posting. This is a rule that members agree to follow.
    Thanks.

    Further to the OP
    Upgrade to BT4 Final or BT4 R1.
    Then read the aircrack-ng documentation.
    Last edited by Archangel-Amael; 10-07-2010 at 11:18 AM.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Similar Threads

  1. Replies: 1
    Last Post: 04-09-2010, 06:43 PM
  2. backtrack 3 freezing when loading realtek drivers?
    By username1 in forum OLD Newbie Area
    Replies: 2
    Last Post: 06-14-2009, 05:54 AM
  3. Loading Drivers and Hangs
    By bigbadlou in forum OLD Bt4beta Non-Working Hardware
    Replies: 5
    Last Post: 02-20-2009, 02:20 AM
  4. Question about loading the Intel Pro Wireless 3945 Drivers
    By FishFilet in forum OLD BackTrack v2.0 Final
    Replies: 2
    Last Post: 12-11-2007, 06:32 PM
  5. BT2:Issue loading network drivers at startup!
    By alexsys in forum OLD BackTrack v2.0 Final
    Replies: 6
    Last Post: 11-02-2007, 08:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •