Results 1 to 7 of 7

Thread: OpenVAS broke after apt-get dist-upgrade?

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    2

    Default OpenVAS broke after apt-get dist-upgrade?

    I just installed BT4 r1 today. Out of old habit I did a apt-get update and apt-get dist-upgrade, and noticed nothing wrong. Not paying attention, I guess.

    However, later I discovered there's no "OpenVAS Server" entry in the OpenVAS menu anymore. I assumed it was a glitch, and tried starting openvasd from the command line, but the file was not found.

    I then decided to backtrace my steps:

    PHP Code:
    root@bt:~# cat /var/log/apt/term.log  |grep -i openvas-server
    Preparing to replace openvas-server 2.0.2-bt0 (using .../openvas-server_2.0.3-bt0_i386.deb) ...
    Unpacking replacement openvas-server ...
    Setting up openvas-server (2.0.3-bt0) ...
    dpkgopenvas-serverdependency problemsbut removing anyway as you request:
     
    openvas-menu depends on openvas-server (>= 2.0.3).
    Removing openvas-server ...
    root@bt:~# apt-get install openvas-server
    Reading package lists... Done
    Building dependency tree
    Reading state information
    ... Done
    Package openvas
    -server is not availablebut is referred to by another package.
    This may mean that the package is missinghas been obsoleted, or
    is only available from another source
    However the following packages replace it
    :
      
    openvas-menu
    E
    Package openvas-server has no installation candidate
    root
    @bt:~# apt-get install openvas-menu
    Reading package lists... Done
    Building dependency tree
    Reading state information
    ... Done
    openvas
    -menu is already the newest version.
    0 upgraded0 newly installed0 to remove and 0 not upgraded.
    root@bt:~
    No, I did not mess with the repositiories, only using the defaults.


    EDIT: Seems like I jumped to conclusions. I reinstalled, and noticed the same problem again, even before running apt-get. Then I checked the live cd: The errors in the apt log are also there, so this was broken by default.
    Last edited by lambon; 10-05-2010 at 10:34 PM.

  2. #2
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    1

    Default Re: OpenVAS broke after apt-get dist-upgrade?

    I am having the same problem with fresh install of Backtrack 4. I ran apt-get dist-upgrade and keep getting these error messages.

    Code:
    root@bt:~# apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      openvas-client: Depends: openvas-scanner (>= 3.0.1-bt0) but it is not installed
    E: Unmet dependencies. Try using -f.
    Code:
    root@bt:~# apt-get -f install openvas-scanner
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
      openvas-scanner
    0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
    37 not fully installed or removed.
    Need to get 212kB of archives.
    After this operation, 926kB of additional disk space will be used.
    Get:1 http://archive.offensive-security.com pwnsauce/microverse openvas-scanner 3.1.1-bt0 [212kB]
    Fetched 212kB in 1s (144kB/s)
    (Reading database ... 234072 files and directories currently installed.)
    Unpacking openvas-scanner (from .../openvas-scanner_3.1.1-bt0_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb (--unpack):
     trying to overwrite `/usr/local/lib/openvas/plugins/synscan.nes', which is also in package openvas-plugins
    Errors were encountered while processing:
     /var/cache/apt/archives/openvas-scanner_3.1.1-bt0_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Is there a fix for this?

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    1

    Default Re: OpenVAS broke after apt-get dist-upgrade?

    it same for me...
    and now i can't booting my backtrack after that...
    just login screen, then black screen...
    how to fix it ?

  4. #4
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    1

    Thumbs up Respuesta: Re: OpenVAS broke after apt-get dist-upgrade?

    Quote Originally Posted by zerofreedom View Post
    it same for me...
    and now i can't booting my backtrack after that...
    just login screen, then black screen...
    how to fix it ?

    possibily have a problem in you configuration the video. try reinstall drivers. I also pass the same

  5. #5
    Just burned his ISO
    Join Date
    Nov 2010
    Posts
    2

    Angry Re: OpenVAS broke after apt-get dist-upgrade?

    Urg... You guys too huh? Yea, it seems to be affecting my system in adverse ways. For some reason I can host my server, because my ports have been locked.?! I get all sorts of socket error msgs.

  6. #6
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: OpenVAS broke after apt-get dist-upgrade?

    Not sure why everyone is using a guide for R1 when both the repos and the R2 have the latest versions of openvas. Further if you are updating tools outside of our repos then you are on your own for help guidance and support.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  7. #7
    Just burned his ISO ckyned's Avatar
    Join Date
    May 2008
    Posts
    6

    Default Re: OpenVAS broke after apt-get dist-upgrade?

    Any solution for this? Updating with "apt-get update && apt-get dist-upgrade"
    Same error found in my hdd installed BT4final & VMware BT4final.
    I have googled for this but end up here.

Similar Threads

  1. WUSB54GC not working after dist-upgrade
    By encrypt in forum BackTrack Bugs
    Replies: 2
    Last Post: 07-28-2010, 01:32 AM
  2. apt-get dist-upgrade issue
    By RageLtMan in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 13
    Last Post: 01-14-2010, 08:12 PM
  3. dist-upgrade and scapy broken
    By bofh28 in forum OLD BackTrack 4 Software Related Issues
    Replies: 4
    Last Post: 01-11-2010, 11:11 PM
  4. Error with Postgresql after recent dist-upgrade
    By imported_davehardy20 in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 15
    Last Post: 11-20-2009, 10:23 AM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •