Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Tor e filedescriptor!

  1. #1
    Member
    Join Date
    May 2010
    Posts
    85

    Default Tor e filedescriptor!

    Pessoal

    É o seguinte, toda vez que inicio o Tor recebo a seguinte mensagem:

    # /etc/init.d/tor start

    Raising maximum number of filedescriptors (ulimit -n) to 8192.
    Quer dizer que tenho que aumentar o número máximo de aquivos descritores para 8192.

    A minha dificuldade é como fazer esse aumento. Fui olhar como estava a configuração, com o camando:

    cat /proc/sys/fs/file-nr
    E obtive esse resultado:

    Code:
    1664  0  38713

    Esse 0 na segunda coluna me diz que não tenho nenhum filedescriptor disponível.

    Como nunca fiz isso, estou com receio em fazer alguma besteira, ainda mais agora que o meu RC1 está bem funcional

    Não sei se para corrigir isso eu devo simplesmente editar o arquivo/etc/security/limits.conf de modo global, ou basta apenas digitar o comando: echo -n "8192" > $( mount | grep sysfs | cut -d" " -f 3 )/fs/file-max, ou ambos e algo mais.

    Desde já agradeço

  2. #2
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: Tor e filedescriptor!


  3. #3
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: Tor e filedescriptor!

    Oi spawn

    Infelizmente a luta continua, vou te explicar as minhas tentativas: no site do Tor que me passou tem lá

    14. (Unix only.) Your operating system probably limits the number of open file descriptors per process to 1024 (or even less). If you plan to be running a fast exit node, this is probably not enough. On Linux, you should add a line like "toruser hard nofile 8192" to your /etc/security/limits.conf file (where toruser is the user that runs the Tor process), and then restart Tor if it's installed as a package (or log out and log back in if you run it yourself).
    Então fui editar o tal arquivo, me confundi aonde que seria o local certo, então eu fiz N mudanças em N tentativas, a linha que adicionei foi esta:

    * hard nofile 8192
    Como sou o único usuário não vi mal algum em deixar o *. Mas também tentei com o root.

    O que mais fiz: também editei o arquivo /etc/pam.d/login

    Acresentendo essa linha: session required /lib/security/pam_limits.so

    O comando ulimit -u, ulimit -n ambos seguidos de 8192

    Sempre reiniciando o Tor, ou parando e inciando novamente, reiniciando o RC1 fazendo uma coisa de cada vez e testando, mas nada. A mensagem que aparece quando inicio o Tor é essa:

    Raising maximum number of filedescriptors (ulimit -n) to 8192.
    Starting tor daemon: tor...
    Sep 28 22:58:03.655 [notice] Tor v0.2.2.16-alpha (git-04ed53b25b260ea7). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
    Sep 28 22:58:03.667 [notice] Initialized libevent version 1.3e using method epoll. Good.
    Sep 28 22:58:03.668 [notice] Opening Socks listener on 127.0.0.1:9050
    done.
    Será que não tem alguma coisa haver com a versão que estou usando do Tor?

    Cara minha cabeça esquentou hehehe. Se tiver mais alguma dica, por favor.

    Obrigado

  4. #4
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: Tor e filedescriptor!

    executa ai

    # cat /proc/sys/fs/file-max

  5. #5
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: Tor e filedescriptor!

    Outro detalhe é o seguinte,
    está funcionando ?
    verifique se ja está ilimitado e o tor esta apenas ajustando o limite para 8192

    http://ss64.com/bash/limits.conf.html
    Last edited by spawn; 09-29-2010 at 04:06 AM.

  6. #6
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    1

    Default Re: Tor e filedescriptor!


  7. #7
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: Tor e filedescriptor!

    Fiz o que falou:

    # cat /proc/sys/fs/file-max

    38713
    Sobre sua pergunta: está funcionando?

    Pelo que entendi da sua pergunta é se o Tor está funcionando. A resposta é sim, veja:

    # netstat -a | grep 9050

    tcp 0 0 localhost:9050 *:* LISTEN
    verifique se ja está ilimitado e o tor esta apenas ajustando o limite para 8192

    Não sei se foi isso que pediu:

    # ulimit -H -a

    core file size (blocks, -c) unlimited
    data seg size (kbytes, -d) unlimited
    scheduling priority (-e) 0
    file size (blocks, -f) unlimited
    pending signals (-i) 3025
    max locked memory (kbytes, -l) 64
    max memory size (kbytes, -m) unlimited
    open files (-n) 1024
    pipe size (512 bytes, -p) 8
    POSIX message queues (bytes, -q) 819200
    real-time priority (-r) 0
    stack size (kbytes, -s) unlimited
    cpu time (seconds, -t) unlimited
    max user processes (-u) 3025
    virtual memory (kbytes, -v) unlimited
    file locks (-x) unlimited
    Obrigado pela força

  8. #8
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: Tor e filedescriptor!

    da uma olhada no arquivo

    /etc/init.d/tor

    e veja a checagem que o script faz



    Att,

  9. #9
    Member
    Join Date
    May 2010
    Posts
    85

    Default Re: Tor e filedescriptor!

    Beleza spawn

    Veja que coisa quando li sua mensagem justamente estava vendo o que me pediu, mas de outra maneira, assim:

    # cd /etc/init.d

    # grep -i "max" tor -R
    Bom, depois segui sua dica e olha como que está o script (separei apenas a parte que nos interessa):

    # Let's try to figure our some sane defaults:

    if [ -r /proc/sys/fs/file-max ]; then
    system_max=`cat /proc/sys/fs/file-max`
    if [ "$system_max" -gt "80000" ] ; then
    MAX_FILEDESCRIPTORS=32768
    elif [ "$system_max" -gt "40000" ] ; then
    MAX_FILEDESCRIPTORS=16384
    elif [ "$system_max" -gt "10000" ] ; then
    [COLOR="red"]MAX_FILEDESCRIPTORS=8192

    else
    MAX_FILEDESCRIPTORS=1024
    cat << EOF

    Warning: Your system has very few filedescriptors available in total.

    Maybe you should try raising that by adding 'fs.file-max=100000' to your
    /etc/sysctl.conf file. Feel free to pick any number that you deem appropriate.
    Then run 'sysctl -p'. See /proc/sys/fs/file-max for the current value, and
    file-nr in the same directory for how many of those are used at the moment.

    (...)

    case "$1" in
    start)
    if [ "$RUN_DAEMON" != "yes" ]; then
    echo "Not starting $DESC (Disabled in $DEFAULTSFILE)."
    exit 0
    fi

    if [ -n "$MAX_FILEDESCRIPTORS" ]; then
    echo -n "Raising maximum number of filedescriptors (ulimit -n) to $MAX_FILEDESCRIPTORS"
    if ulimit -n "$MAX_FILEDESCRIPTORS" ; then
    echo "."
    else
    echo ": FAILED."
    fi
    fi
    Acha que devo seguir a sugestão: 'fs.file-max=100000'

    Uma dúvida em "$system_max" -gt o que significa o -gt?

    Estava lendo a respeito do squid, ele não vem instalado no RC1, acharia interessante tentar algo por ele? Ou será que seguindo a sugestão acima já vai resolver?

    Mais uma vez muito obrigado

  10. #10
    Good friend of the forums spawn's Avatar
    Join Date
    Jan 2010
    Posts
    280

    Default Re: Tor e filedescriptor!

    nao amigo, vc n precisa alterar nada, o proprio script ajusta para o tor de acordo com o seu sistema

    Att,

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •