Results 1 to 4 of 4

Thread: "Could not connect to wicd's D-Bus interface." error workaround

Hybrid View

  1. #1
    Junior Member 5cardcharlie's Avatar
    Join Date
    Sep 2010
    Location
    Ohio
    Posts
    45

    Default "Could not connect to wicd's D-Bus interface." error workaround

    Some other forum members and myself have had "Could not connect to wicd's D-Bus interface." pop up when starting X. The log, however, shows no errors. Enabling network start on boot solves the issue, but can be annoying to some of us. I've found a simple workaround that removes the error without starting the network at boot.

    Move wicd-tray.desktop out of etc/xdg/autostart and place it somewhere else if needed later. Now when starting up, the error will be gone, but will pop up again if you start wicd-client or wicd-gtk. To prevent this, networking has to be enabled first.

    To start networking and the wicd gtk interface in one click, you can right click on the Services>NETWORK>"WICD gtk interface" selection and select "edit item". Then change the command to:

    Code:
    sh -c "start-network && wicd-gtk"
    Now the error's gone, networking doesn't start at boot, and wicd is enabled with one click

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: "Could not connect to wicd's D-Bus interface." error workaround

    I posted a solution to this problem from the beginning

    Code:
    dpkg-reconfigure wicd
    update-rc.d wicd defaults
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Junior Member 5cardcharlie's Avatar
    Join Date
    Sep 2010
    Location
    Ohio
    Posts
    45

    Default Re: "Could not connect to wicd's D-Bus interface." error workaround

    Yes, and I tried your fix, but it started network at boot. I'd rather not do that if I can avoid it.

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: "Could not connect to wicd's D-Bus interface." error workaround

    Here are 2 ideas, 1 go search the forums. It's a rule you agreed to uphold and follow. So now is a good time to start.
    Second, if you don't know what commands you are running then it might be good to look into them. I mean how to do know the guy didn't just post a command to delete your hard drive(s).
    If these two tasks are to much for you then go back to whatever operating system you came from. We are not here to teach you how to use linux.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Similar Threads

  1. Replies: 4
    Last Post: 02-24-2011, 04:52 PM
  2. Replies: 1
    Last Post: 04-17-2010, 06:36 AM
  3. Wicd says "This network requires encryption to be enabled". Why?
    By balding_parrot in forum Frequently Asked Questions
    Replies: 0
    Last Post: 02-28-2010, 06:36 AM
  4. Replies: 1
    Last Post: 07-28-2008, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •